Alfa Romeo Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
My 89 Spider seems to have a short or possibly a bad voltage regulator. When I turn on the HVAC fan the volt meter dips from 13-14v to less than or equal to 12v. Has anyone had this problem? Sometimes the battery light comes on and sometimes not.

In one instance I was cruising down the highway at about 70-75 at night with the head lights on and I turned on the blower and the battery light came on.

In another instance I was Idling the car with the headlights on and turned on the blower same dip in voltage and no battery light.

Also what is the purpose of the Blower reminder light? Is it a light that tells you when the auxiliary electric cooling fan comes on? The only thing I found in the manual was the name of the light.

Third question does anyone have any experience repairing the speedo's or Tach's? Mine tries to work but basically sits around 40mph all the time and the tachometer works but bounces around and seems fairly inaccurate.

Thanks,
-Ken
 

·
1966-2013
Joined
·
13,741 Posts
The blower reminder lamp indicates that the heater fan is turned on.
Lit dim is low speed, lit bright is high speed.

There's a good thread in the sticky FAQ regarding repair and calibration of the monopod speedo that is prolly worth a look.

Don't panic too much about the voltmeter indications until you can confirm that the gauge is indicating correctly. They are more of a 'rough idea' type device rather than 'absolute value' thing.

And we'll be needing pictures in return for information.
 

·
Registered
Joined
·
1,961 Posts
Welcome to the BB.
I'll bend the rules here...First posts with no pic's we don't take seriously Ken...after all we don't even know the colr...LOL.
Send the speedo pod to Palo Alto Speedometer
Discharge light issue and voltage drop are known common facts of life.
You can improve or eliminate the problem by running a parallel red wire to the existing one from the alternator to the main power distribution "box" black junct box on the drivers fender on the engine compartment. Also make sure the connections for the ground strap...trans housing to vehicle frame above the clutch slave are clean good connections. Also ground connection at battery in trunk.
Blower reminder? It is just to remind you that the cabin blower is on...and whick speed (lo dim, hi brite).
Elio
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
O sorry I didn't know the protocol. How do you post images on here? Do you really have to link another site with the image?
 

·
Registered
Joined
·
1,742 Posts
O sorry I didn't know the protocol. How do you post images on here? Do you really have to link another site with the image?
Not a protocol so much as an obsession! If the guys don't ask, Eric will for sure :).

I host offsite at photobucket. The site makes all of the code for you to paste into the post easily.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Speak of the Devil

There it was on the ebay adds at the bottom of the page. Well not exactly....but this one is the same except mines a bit more worn out. This is the exact same model and color and pretty much identical down to the new tan top.

Alfa Romeo : Spider | eBay


I would like to make mine look like this one. I will upload some real pictures of the automobile in question.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Real Pic

Okay I attached a real picture its not the greatest. Truthfully I haven't taken that many pictures yet. I just bought the car in Beaufort, SC. It seems to run pretty good aside from needing a valve adjustment. The paint is faded from the southern sun but they told me they always kept it garaged and never drove it in the rain. I got underneath it and couldn't really see any Rust. The only place I've really found any so far is on the front spoiler were it looks like someone probably hit one of the those concrete parking lot bumpers.
 

Attachments

1 - 8 of 8 Posts
Top