Alfa Romeo Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
642 Posts
Discussion Starter #1
Okay, I give up.

I've done this twice before, back in 2003 and 1996, but I just can't seem to remember how to "git-er-dun".

I had new bushings pressed into my front lower control arms. They came with the oil impregnated foam seals. The problem is that once I get the arm on the shaft with all of the various washers in the right order I just can't get the nut on. I was tackling it from the side so perhaps I can try from under the car.

Any helpful suggestions ?

Thanks,

Dan
 

·
Registered
Joined
·
867 Posts
Hi Dan,

The foam/felt that they supply is to thick, i had the same problem, i replaced the foam with Neoprene with self adhesive @ $20. for 50cm. I cut it in half so that i have 2 X 25cm strips and then stuck them together and then used a punch to cut the inner hole and used scissors to cut the outer circle.

Unlike the felt Neoprene
  • Resists degradation from sun, ozone and weather
  • Performs well in contact with oils and many chemicals
  • Remains useful over a wide temperature range
  • Displays outstanding physical toughness
  • Resists burning inherently better than exclusively hydrocarbon rubbers
  • Outstanding resistance to damage caused by flexing and twisting
Does not absorb water and always holds its form. Just make sure you have installed the large washer in the correct side and apply plenty of grease, you will find that nut will fit, wipe the access grease and your done.

I purchased neoprene from Clark Rubber.

Hope this helps you,
Rich
 
1 - 2 of 2 Posts
Top