Alfa Romeo Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
I asked this on the general board - thought I throw one here as well - I own a 88 Spider Quad - owned since 94 - speedo has never worked - sender is OK - don't have a clue what's wrong - been driving by the feel of the car - but I guess it would be nice to have an idea of how fast you are gong - anybody have a ratio of how fast you are going by the gear to the rpm's?
 

·
Registered
Joined
·
1,960 Posts
Here are some reference points from Alfa's product bulletin for the 115 model USA version (PA381500000000) Jan 86.

5th gear 5000rpm = 180km/h 1700rpm = 60km/h

4th 5000rpm = 140km/h 2000rpm = 59km/h

Y = mX + b remember?

Palo Alto speedometer is the place for a fix.

Best regards, Elio
 

·
Registered
Joined
·
246 Posts
Bob,

Had the same problem on my 88 quad, ended up shipping off to Palo Alto to have it repaired, part of my problem was that the pointer had "jumped" the stop and therefore could not move. There is a great thread here. Also on page 5 of the thread you will find an rpm/speed chart . The mono pod in our 88s is pretty much the same as in the 91-94 models.

Guy
 

·
1966-2013
Joined
·
13,741 Posts
Nice, but why are the seats in the wrong positions?

Or more specifically, what is the reason for whatever it is you've got going on with the seat shoulder seatbelt guides and seatbelt arrangement? (not even close to right, nor safe)
 

·
Registered
Joined
·
460 Posts
Nice, but why are the seats in the wrong positions?

Or more specifically, what is the reason for whatever it is you've got going on with the seat shoulder seatbelt guides and seatbelt arrangement? (not even close to right, nor safe)

looks like the belta are wrong. the round knob for reclining is correctly inboard of he seats???????
 

·
1966-2013
Joined
·
13,741 Posts
Ya.

Kinda looks like the seats were reskinned and there was confusion when punching the holes for the belt guides or the wrong back ended up with the wrong base.

Either/or, a switch of the seatbacks would cure the problem, though there's definitely something goofy going on with the drivers side latch mechanism (see it hanging off the guide in the last pic?) and the passenger side looks to have a couple double-backs on itself before it even hits the guide from behind.

**

Not trying to pick or give you grief Bob, but that's a pretty horrifically dangerous arrangement you have going on there.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #10
Seat Belt question -

This Quad is equipped with the two-point motorized seat belts - they open and close as you start the car and open the door - sometimes a real pain in the *** but they are in the corect position. The mechanism travels along the floor below the door.

I can also detach at the moving mechanism and check into a stationary connector if I want to connect iot manually.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #14
No lap belt

No - this is not a lap belt - apparently they dropped this type of belt during the 1988 production year - so some have it and some have the conventional seat belt system.
 

·
Registered
Joined
·
218 Posts
You might want to start looking for a gas station.....:D
 
1 - 17 of 17 Posts
Top