Alfa Romeo Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
156 Posts
Discussion Starter · #1 ·
Hi guys,

I have found my issue about battery blinking light. The issue is related about horn.

Depending of the situation (maybe pair day versus impair day) I have the ton correctly or just only the low.

So I would like to looking of wiring and connectors about horn to cleaning it and reconnect correctly.

But...I dont know where is the horn...Do you have pictures or good way to looking about that ?

Thanks :)
Regards,
 

·
Registered
Joined
·
291 Posts
Front left corner of the vehicle, behind the bumper (under the headlight).

 

·
Registered
Joined
·
291 Posts
Depends how little your hands are :p . The wires pass from the engine bay, through a hole and down to the horns.

My car is right-hand drive (Australia), and V6. Your car might be different. The wires go to a relay for the horn, behind the headlight. Then the wires pass from the relay to the horn. You might have a problem with the relay or the connections or the horn.

 
  • Like
Reactions: Goned75

·
Registered
Joined
·
131 Posts
is this the same location on the GTV6? Or rather supposed to be? I seem to have one horn on each side of the grill.
 

·
Moderator
2015 Chevy (Holden) SS, 1989 Milano (Shankle Sport), 1991 164S
Joined
·
17,327 Posts
My mechanic always said, first clean all electrical connections you can get to in the particular questionable system. Alfa used to pay the mechanics a certain amount per connection cleaning, finishing with using dielectric grease.
 

·
Registered
Joined
·
1,338 Posts
GTV6 had one on each side. North American Milano's have them as described above.
 
1 - 9 of 9 Posts
Top