Alfa Romeo Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
I was able to successfully remove the original hood prop bracket, and I have received a new one to install, but the actual hood prop rod doesn't seem to be at the right angle. Mine is pretty much a straight 90° angle, and it doesn't seem to follow the line of the bracket to slide freely. I've attached some pics of what I mean.
Does anyone have pics of what the proper angle for the hood prop is supposed to be?
1618421
1618422
1618423
 

·
Registered
Joined
·
534 Posts
There should be a enough sideways movement in the post to allow fitment into the plastic runner
 

·
Registered
Joined
·
961 Posts
Looks like the alignment is only a bit off. Maybe see if you can push the lower portion of the rod deeper into the spring to see if you can position the top end a bit more outboard. If that doesn't get it, maybe just try bending the lowest 90 degree angle a bit in a vise to arrive at a better alignment at the top. Just thinking out loud.

Peter
 

·
Registered
Joined
·
44 Posts
Discussion Starter #6
Thanks, everyone, for your input. I tried pushing the rod further into the spring, but it really doesn't seem like there's any room. If someone has actually done that, with the grooved end outboard of the bracket, that would be interesting to know. I ended up doing a very subtle bend at the lowest angle (where it goes into the bracket), and that seems to have solved it. It looks like there should be a retaining ring on that grooved portion, but I haven't ever seen that. It seems like the only thing holding the post in is the spring.
 

·
Registered
Joined
·
2,321 Posts
The installed position of the white plastic support determines the resting angle of the hood. On my son's GTV 6, the rod does have a slight bend near the top.
 
1 - 8 of 8 Posts
Top