Alfa Romeo Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter #1 (Edited)
Came to read up on oil pump issues and realised I haven't set the first post in here. This is it. I'm facing some lower-than comfy oil pressure in the Spider, wanted the 'skinny' on the "new" pumps available. Have the original 2L lump sitting on a trolly as a "garage storage limiting device" ATM, a 1750 in the Spider, all Weber'd up. That has about 80K miles on it and I intended to get a new pump and do a bearing renew. Now I'm concerned that the better route may be to use the 2L pump (after disassembly/inspect/check-ball, etc.).

Any direct input would be appreciated.

Good info and y'all seem friendly enuff. ;)

Mind if I pull up a chair 'n have a sit?

EDIT: Does th' newbie have to buy the house a round? ;)
 

·
Registered
Joined
·
93 Posts
Discussion Starter #2
*bump*

...sooo.... not as friendly as first imagined?
 

·
Registered
Joined
·
4,631 Posts
Hiya and All that Jazz

*bump*

...sooo.... not as friendly as first imagined?
Patience.....sometimes answers come swarming in and other times bbers are behind in their reading due to special events. In this case, the day of your original post many bbers that drove or flew were already on their way to the National AROC convention or the pre-week activities which ended August 5th, so it will take a while for many to catch up on their reading and respond.

Another suggestion is to post your inquiry on the forum under the specific model of Alfa that you are working on --- many only read those specific forums and not the general forums. You will probably get faster results there. If you do not find help here you can always try posting your question to the Alfa Digest; there are many who read and respond to both.

Btw, welcome to the bb.
 

·
Registered
Joined
·
93 Posts
Discussion Starter #4
Well, it was more intro than inquiry actually. Just found it strange ~nothing~ was posted as a response.

Thanks fer th' reply. :D
 
1 - 4 of 4 Posts
Top