Alfa Romeo Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,542 Posts
Discussion Starter #1
Made a left hand turn....Spider died and won't start! It apparently heard me order it some parts and it is conspiring against me!

Publio:(
 

·
Administrator
Joined
·
16,626 Posts
Did you get it fixed? (Try pushing it through a right hand corner...)

When you say it won't start do you mean it cranks but won't catch or that you turn the key and nothing happens? Is anything working (dash lights, headlights?) or nothing works?

My guess is something electrical - check battery cables, loose wires from ignition switch, blown fuse. If nothing wrong there (and it cranks but won't start) check for spark. Hook a spare spark plug onto a spark plug wire, ground the threaded part and have someone crank the engine while you watch the spark plug. If there is a good, steady spark then the ignition system is functioning.

If there is spark but it won't start then it must be lacking fuel. (You do have gas in the tank, right?) Check the fuel pump fuse (under the parcel shelf behind the seats).

If there is no spark then check the flywheel sensors. Info is in the L-jet page in my signature.

HTH
 

·
Registered
Joined
·
1,542 Posts
Discussion Starter #3
LOL...It cranks with ample current but no catch. Checked the fuses (including the fule pump fuse). I'll check for spark today. Also, fule pump and filter are new as is the hose in the tank. I almost put my foot through the door on this car yesterday. LOL

Publio
 

·
Registered
Joined
·
1,542 Posts
Discussion Starter #4
Well, went to check the spark at the plugs today and the car started right up. Gremlins?

Publio
 

·
1966-2013
Joined
·
13,741 Posts
Prolly.

Or did you by happenstance be rolling through a wet spot when it originally happened? (you never know what a splash of water is going to do)

Still, it'd be worth going through and checking/cleaing connections again, particularly in the coil area and around the starter & camcover stuff.
 

·
Registered
Joined
·
398 Posts
If it happened while going around a turn, and then cleared up after sitting for a couple of days, I wouldn't rule out the possibility of a faulty ground somewhere. If it is a bad ground, you'll eventually find out, because it's not going to go away by itself, but will more likely worsen with time.

Tim
 
1 - 7 of 7 Posts
Top