Alfa Romeo Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1 (Edited)
Hi All

I don't have a foot switch for the wipers and knew it was going to be a mess of wires that someone had put a work around in. There was an after market wiper switch for wipers, the original switch wires where attached to the fan switch and the fan wires were taped up. fun..

anyhow I have find the wiring to the wipers/switch/foot switch, connected the new fan motor. now I have to order a new wiper foot and dash switch.

but I have also found wires for things that I cant identify.

most of the wires are tied together with the wiper wires near the heater unit, on my RHD car these wires are on the left side of the steering column near the centre of the car behind the cig lighter
all wires have female ends,

1st pic shows a group of 5 wires, they are long. White/Black, grey, blue, and black

2nd pic. back of red plug to fuel gauge. black wire long. where does this go to.

3rd pic. a white and a black wire.

4th pic. 3 female connectors with 4 wires. 1 connector has both a white and black wire sharing the connector. the other 2 is 1 white and 1 black.

if anyone could point me in the right direction it would be very appreciated.
 

Attachments

·
Registered
Joined
·
3,531 Posts
What year is your car? Do you have the wiring diagram? That will make this easy. Using the diagram from my 73...

4th pic... pretty sure those go to the defog relay.
3rd pic... tough one - need more clues.
2nd pic... i want to guess ground? does it have a ring terminal? i believe grounds were the only ones that had ring terminals under the dash
1st pic... that color grouping has a windshield wipery vibe to it. I'd guess the console wiper switch.

OBVIOUSLY YOU NEED TO USE COMMON SENSE and not take blind faith in what some guy on the innernet tells you =) Be careful.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #3
It's a 74 1600 junior with the early 1750 style dash.

There are too many wires compared to the diagram. Even the toggle switch has to many wires. All look correct colour but have multiple wires per connection.
having a rethink, the diagram suggest all blue, blue/black, blue/white and grey seem to be wiper. So switches on order and will start from scratch.

Not sure what the black/white is in pic1, it has power.

All connections in all pics have a female ends. No ring. but they could have been replaced.
Is there a plug for the foot switch? I suspect if there is it's been cut off and female crimps added to the ends.
Be nice if someone has a photo of the foot switch with wires attached they can share...
 

·
Registered
Joined
·
3,531 Posts
Yes there is a 4 position molex connector at the footswitch (gray, blue/white, blue/black) .

I can take a pic of the molex for you later - don't have the actual switch handy.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #5
thanks that would be great.

couple of extra pics, cant see the wire colours very well but they are correct, but the switch wires you can see, 3 of the female connectors have 2 wires on a single connector, the diagram doesn't reflect this.
 

Attachments

·
Super Moderator
Joined
·
10,599 Posts
Do you have the wiring diagram?

YOU NEED TO USE COMMON SENSE and not take blind faith in what some guy on the innernet tells you =)
Those are two of the best pieces of advice I have seen. To those, I would add:

- Do you have a voltmeter?

- Even if you have a wiring diagram, do the color codes of your wires match those shown on the diagram? Alfa made subtle changes each year, which is one reason why when "some guy on the innernet" tells you "oh, just hook the green/black wire to terminal #b-2", you really need to understand the circuit before blindly following that advice.
 
1 - 7 of 7 Posts
Top