Alfa Romeo Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi, my alfa is a 155 TS 2.0 with manual transmission. The engine has revving problems. It needs 10 seconds to rev from idle (900rpm) to 2000rpm but when it reaches 2000rpm, it can rev up to its redline with no hesitations. Car can be driven normally at highway speeds due to the high rpm but can be a pain in the arse in Stop and Go Traffic especially on inclines.

Already replaced spark plug, fuel pump, fuel filter . . . cleaned air filter and the 3 sensors on the intake manifiold tube.

I am from Manila Philippines, Alfa Romeo closed shop back in 1998... Local Mechanics are not familiar with my car. What can i check or replace??

Thanks in advance

Mark
 

·
Registered
Joined
·
783 Posts
it might help if you tell if its 8 valve or 16 valve engine, maybe someone could help..
 

·
Registered
Joined
·
2,687 Posts
Try alfa155.org. The fine lads there should be able to set you in the right direction.
 

·
Registered
Joined
·
1,566 Posts
Has the problem just arived or has it been there all the time, you have owned the car?
Depending on on how bad the hesitation is, rearly bad, have a diagnose done (a Bosch tester should be able to communicate with the ECU); is it just slow to accelerate, it is part of the engine set up, unfortunatly. Early versions of the 16 valve 2,0 TS had this problem. I felt it was unacceptable like you. I had an UniChip fittet to the ECU and mapped on a rolling road. It improved the both the tourque (Nm) and power (HP) by up to 15%, but it was still a bit slow at low revs.
Erik
 
1 - 5 of 5 Posts
Top