Alfa Romeo Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
264 Posts
Discussion Starter · #1 ·
Hi all, I finally got my hands on a hardtop and have it installed on my spider. The dome light comes on and off with the doors but the switch doesn't do anything and the map light doesn't work. I want to pull it off and see what's going on but can't figure out how and am terrified of breaking it.

Does anyone know how to get the thing off?

Thanks!
 

·
Premium Member
1988 Spider Quadrifoglio
Joined
·
264 Posts
Just pull'r out. Those plastic interior trim tool sets on Amazon come in handy.
 

·
Registered
Joined
·
264 Posts
Discussion Starter · #3 ·
Got it out, thanks! Unfortunately it's not as easy of a fix as I'd hope as the map light and the switch are both operational. Time to trace back the wires...
 

·
Premium Member
1988 Spider Quadrifoglio
Joined
·
264 Posts
The red/black wire should be at +12V unswitched, the white/red wire should be +12V with the doors closed, grounded when the doors are opened. Black is ground.

Door lamp is wired between red/black to white/red.

Map light is wired between red/black and black.
 

·
Registered
Joined
·
264 Posts
Discussion Starter · #5 ·
Thanks, I think the issue is the black ground isn't grounding properly so I'll have to trace that wire.
 

·
Registered
Joined
·
9,731 Posts
Thanks, I think the issue is the black ground isn't grounding properly so I'll have to trace that wire.
the map light switch on the hard top is made of the cheapest cr*p..........I bought a NOS light ($$!) and it broke after 10 minutes:)

just add a temporary ground wire to test it?
check the connector behind the door
Ground point should be G54a (Iiirc, this is in the trunk, left side behind carpet
1626975095888.png
but as it is the same bundle for the fuel gauge....I'd suspect if the gauge is working the ground is good.......?

1626974853200.jpeg 1626974885870.jpeg
 
1 - 6 of 6 Posts
Top