Alfa Romeo Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
I just got a very good deal on a 1981 Alfasud 1500

Its in very good condition for a sud. Only rust is in the bonnet and some around front windscreen wiper.

The car has been sitting in a garage for the last 15 years unused. Of course the front brakes are seized :(

What do I need to do to the engine before attempting to start it?
What type of oil does it like?
 

·
Registered
Joined
·
45 Posts
Hey, Congrats. I loved my sud.

You need to do all the fluids, and I mean all. Engine oil (15/40 or 20/50), coolant (50% coolant, 50% distilled water), brake fluid (it's also the clutch fluid as well) and transmission fluid. Change your oil, fuel and air filter. Replace your spark plugs, leads and clean up your dizzy cap and rotor. You should also drain the tank as fuel does go off. If you pull the tank out, put a few litres of diesel in and some nails/bolts. Shake the crap out of it and drain it. This will clean out all the rust. Quickly fill it with fuel otherwise it will rust again in a matter of hours.

You will need tyres. They may look good but they are not. 15 year old tyres will kill you no questions asked. They go very hard in the tread and very soft on the side wall. You don't want a front tyre blowout at 110km/h.

You will need new brake pads. Same as tyres, they do go 'off'. They get very hard and stop working as they should.

After that you should be good to go.

cheers

Scott
 

·
Registered
Joined
·
61 Posts
Discussion Starter #3
Thanks for the reply. I will do as you suggest. I definitely wont be using the old tyres. They have become flat on the bottom anyway.

I see the Haynes manual suggests Golden Lodge spark plugs. I cant seem to find them here in New Zealand. What other plugs can I use?
 

·
Registered
Joined
·
45 Posts
Just use NGK's. I always use platinum's as on the 16V they are a pain to replace and the platinum's last 100,000km.

cheers
Scott
 

·
Registered
Joined
·
61 Posts
Discussion Starter #5
I spent the whole day today trying to get the brake calipers out to have them reconditioned. Only managed to get one brake disc out. Not enjoying the inboard brakes so far ;)
 

·
Registered
Joined
·
536 Posts
Wait until you must adjust the handbrake.....


Before you start the engine you should probably poor little oil inside the cylinders to avoid damaging them ( from the spark plugs holes. 15 years are lots of time and that protective film from the lubricant is certainly gone. it is common practice for engines that have been unused for long long time...
 

·
Registered
Joined
·
61 Posts
Discussion Starter #7
well i managed to lose the two bleeder screws. Anyone know what size they are and where to get replacements?
 

·
Registered
Joined
·
61 Posts
Discussion Starter #9
New oil, new coolant, new oil filter, new spark plugs and new leads. Turned it over a few times and it fired into life and is running perfectly and starting first time every time after 15 years of sitting idle. :D
 

·
Registered
Joined
·
2 Posts
You need lodge plugs preffered or at a push NGK

I would try a fresh battery and fresh fuel see if it goes? Pump the throttle a few times and see. She might just surprise you
 
1 - 10 of 10 Posts
Top