Alfa Romeo Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
146 Posts
Discussion Starter #1
OK
I have a milano that I am working on and it has supposedly had the GUBI fix on it.

Here is what is going on.

The 3 idiots lights on the instrument cluster do not illuminate nor do the 7 lights on the ARC.
The interior lights come on instead.

What I have done so far is pull the relay for the interior lights
And I tried a spare ARC unit that I had laying around with no luck.

Please tell me I am overlooking something obvious.

KL Harper
 

·
Premium Member
Joined
·
844 Posts
Nothing Obvious in the ARC

Hi KL

Hopefully you've already fixed this issue. If not here are some thoughts.

There is not nearly enough detail in your post, secondly you need more specific descriptions.

Okay you said.

"....The 3 idiots lights on the instrument cluster do not illuminate nor do the 7 lights on the ARC...."

I assume you mean the low fuel light, the low oil pressure light & the overheating coolant light. Also when you say they do not come on, do you mean they do not come on when the car is first started, or they never turn on? In any event you can check the oil and coolant temp idiot lights by grounding the respective sensor lead.

With the lead grounded the light should come on.

Then you say
"....And I tried a spare ARC unit that I had laying around with no luck...."

When you say ARC do you mean the ARC display unit in the dash or the ARC "computer" hidden behind the dash above the glove box.

Anyway let us know what you find.

Bye
 
1 - 2 of 2 Posts
Top