Alfa Romeo Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi Gents!
You were a great help with my last issue so I'm back again.
I have an '88 Graduate that just failed the air quality test in Colorado. It failed on the HC portion of the test. I believe this is because I still had a can of BG injector cleaner in the tank when I did the test. I have another tank of gas in there now and changed the plugs and cleaned the air filter (K&N). I'm hopeful it will pass next week after I run this new tank of gas through.

Question: There is a heavy smell of gas coming from the engine when I run the car. I have to leave the garage door open when I park to let the smell dissipate. Do any of you have experience with this? It's like there is excess fuel running through the engine that isn't being burned off.
I haven't noticed any leaks or hoses that are loose around the injectors, engine manifold or exhaust manifold. I did find a big band-aid like clamp on one of the exhaust manifolds... like something had cracked and they put a big clamp on it. Other than that everything seems solid, it's just that gas smell is worrying.

Thanks in advance!
 

·
But Mad North-Northwest
Joined
·
12,735 Posts
Sounds like you're running rich. I'm pretty sure an exhaust leak upstream of the O2 sensor can cause rich running. The fresh air makes the sensor think the engine is lean. Has it ever passed smog?

Beyond that, go through the L-Jet troubleshooting guide fully: Bosch L-jetronic Fuel Injection Idle Adjustment Diagnostic and Tune Up Technical Article Alfa Romeo Spider Specific

And replace that crap K&N with a good paper filter: http://www.alfabb.com/bb/forums/164-168-1991-1995/197768-k-n-filters-thoughts.html
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
Sounds like you're running rich. I'm pretty sure an exhaust leak upstream of the O2 sensor can cause rich running. The fresh air makes the sensor think the engine is lean. Has it ever passed smog?

It passed smog a few months ago but Colorado requires the new owner get it smogged. It failed on the HC.
When you say exhaust leak upstream of the O2 sensor is that between the AFM and the Throttle position switch?
 

·
But Mad North-Northwest
Joined
·
12,735 Posts
Exhaust leak would be in the exhaust. Somewhere in the exhaust manifold or the downtube. Reason I mention it is that "clamp" you describe on the exhaust manifold sounds suspicious.
 
1 - 5 of 5 Posts
Top