Alfa Romeo Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
I have a 78 alfa spider that I replaced the short piece of hose in the fuel tank at the tank sending unit. since that time I have been getting gas fumes, increasingly worse, in the passenger compartment, didn't smell a thing before that! I went back and resealed the sending unit/pump and am absolutely positive that it is sealed. the filler hose appears completely intact I can find no gross leaks/wetness any where. At times the fumes are overwhelming even with the top down. I really don't want to pull the tank:eek: Any ideas??
 

·
Registered
Joined
·
45 Posts
Discussion Starter #2 (Edited)
Problem solved

I have a 78 alfa spider that I replaced the short piece of hose in the fuel tank at the tank sending unit. since that time I have been getting gas fumes, increasingly worse, in the passenger compartment, didn't smell a thing before that! I went back and resealed the sending unit/pump and am absolutely positive that it is sealed. the filler hose appears completely intact I can find no gross leaks/wetness any where. At times the fumes are overwhelming even with the top down. I really don't want to pull the tank:eek: Any ideas??
After pressurizing the fuel tank I found the anti siphon valve leaking the wrong way. It seems the extra flow/pressure from the fixed fuel hose in the tank caused the fumes to occur. Most of the anti siphon valves I have dealt with are built into the fuel pump. It seems the back pressure fixed the problem, at least for now. This is a spica system by the way
 

Attachments

·
Registered
Joined
·
45 Posts
Discussion Starter #4
Hoses

Yes I suppose all original as most of the car is. Everything seems very well intact though.
 
1 - 4 of 4 Posts
Top