Alfa Romeo Forums banner

1 - 4 of 4 Posts

·
Registered
1971 Alfa Romeo Spider 1750 Kamm tail
Joined
·
74 Posts
Discussion Starter · #1 ·
Hello,

I filled my car up for the first time since I've owned it and my fuel gauge needle only goes up to a bit more than 1/2 a tank. The car is a 1983 SV.

What do you think it may be? What should i look into first?

Any suggestions??

Thanks Alfa friends!!

ED
 

·
1966-2013
Joined
·
13,741 Posts
I suppose the first thing you could do is take the gauge sender wire to ground and turn the key on to see if it pins the gauge at max.

If it doesn't, then the issue is likely the gauge or its ground.

If it does, then a good cleaning of the wires and contacts, particularly the ground, on the sender would be in order, and if that didn't bring it, likely the float arm needs calibration.
 

·
Registered
1971 Alfa Romeo Spider 1750 Kamm tail
Joined
·
74 Posts
Discussion Starter · #3 ·
I suppose the first thing you could do is take the gauge sender wire to ground and turn the key on to see if it pins the gauge at max.

If it doesn't, then the issue is likely the gauge or its ground.

If it does, then a good cleaning of the wires and contacts, particularly the ground, on the sender would be in order, and if that didn't bring it, likely the float arm needs calibration.
Great info....Thanks for the response!!
 

·
Registered
Joined
·
2,068 Posts
the spiders also have a bad habit of making you baby the fill hose. both of mine stopped the fill nozzle with quite a bit of room in the tank. you have to pull the nozzle out a bit to get the last several gallons in.
cliff
 
1 - 4 of 4 Posts
Top