Alfa Romeo Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter #1
I just put in a new fuel probe and when I am standing still, the gauge reads fine. But when i start to drive, the gauge goes crazy, from 0 to 3/4 (which is an accurate reading) to full to half. All of these movements are very fast and jerky. One thing I did try was moving the wire harness that connects to the probe, in a was jamming it with a screw driver so I could look at the cluster, and it showed empty. So, my thought is a possible wiring harness issue.

Any other thoughts?
 

·
Registered
'91 164L 3.0 V6 12V 5-speed
Joined
·
54 Posts
I'll continue with this old thread.

I assume some fluctuation is normal for these cars but how much is the question. Mine is moving violently when going over speed bumps or on rough roads and just showing anyhing it wants when cornering. Is this normal?
 

·
Premium Member
Joined
·
15,626 Posts
The gauges in my 164s have always just read about 1/4 tank low when these cars are tilted nose down in our driveway, and read about 1/4 more full when driving uphill. Other than that, they doesn't bounce wildly at any time.

"One thing I did try was moving the wire harness that connects to the probe, in a was jamming it with a screw driver so I could look at the cluster, and it showed empty"

So, I would assume there is a wiring/grounding problem as well. Damaged with the screwdriver?
 

·
Registered
'91 164L 3.0 V6 12V 5-speed
Joined
·
54 Posts
That's reasonable but mine is moving much more when driving along, so much that the gauge appears very inaccurate. When cornering the needle drops and raises but so slowly that it seems it's actually never still.
 
1 - 4 of 4 Posts
Top