Alfa Romeo Forums banner

1 - 20 of 38 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter #1 (Edited)
I will sell all my Alfa **** for the right price. Includes clear title 85 white sunroof GTV6 w/ worked 3.0(just rebuilt and broken in: carillo rods, venolia 10.5 pistons, hastings rings, all new gaskets, H20 pump , thermo tensioner, valve job, some mild port smoothing, C+B cams hot street, new injectors, no smoke + perfect oil pressure, idles about 850-900), no second gear grind if warmed up, good glass, brand new IAP headers with thermal wrap to the down pipes, JAg hood vent really keeps everything cool under the hood, minimal rust in usual places, started putting on chrome bumpers to save weight (have front and rear and many bumper shocks).. gentle dent passenger side right rear does not affect side crease of rear quarter panel or wheel arch, no other dents...

you need to know that there is an electrical fault which I have become VERY frustrated in trying to find.NOT AN ELECTRICAL FAULT..TURNED OUT TO BE A CLOGGED GAS 'IN'-TANK FILTER..RUNS FINE NOW) Anyway, everything fron airmass sensor to the entire ignition dizzy/ spark plugs/ coil/computer to O2 sensor to injector to fuel pump/fuel pressure reg to ECU to wiring to the entire engine has been replaced and the problem still persists. I have checked everything I know and can't find it.....she will be a great car if you can track down this gremlin!!!!

includes spare 3.0, running and no leaks(recently rebuilt w/ new valve springs, valve job, liners, standard pistons and rings, new h20 pump, all new gazskets, timing belt, bearings..about 200 miles on engine), combi relays, brake vac booster spare LSD tranny( i was informed that is is an lsd tranny but the flanges spin oppositely....it is out of a milano w/iso links and single clutch disc), extra new and old clutches, about 1000 parts old and new, brand new Ronal 5x98 rims and 225 tires all around, and the garage banners, lots of new gaskets... extra air mass sensor (one to run richer and one stock and one bigger from BMW), extra 3.0(w/extended rev resistor) and 2.5 computer, and much more

Parts include things like window motors, brake , fluid reservoirs, spare slave cylinder, wiper motor, linkages, wheel bearings, seals, axle boots, mirrors, xtra bumpers, 3.0 liners, connecting rods, spare set of 3.0 heads, valves new and used, extra shims, front grille, set of extra headlights w/H bulbs, steering rack, outer tie rods, steering wheels, brake parts, interior parts, door handle surrounds, bosch parts, extra new tires and original rims, some alfa tools, extra side vents, alfetta chrome front grille, axles, Guibos new and used... and much more

The whole lot to go at one time...Any 'reasonable' offer considered, I am in no hurry to sell but I have my eye on another vehicle....wife says "can't have new one until old stuff goes!"

[email protected]

PS: I am in Michigan near Detroit
 

Attachments

S

·
Guest
Joined
·
0 Posts
Another Alfa, I hope.

I can't believe you're giving up on this thing, man. You've invested a lot of time and energy into it. Seems like a rash decision based on frustration.....maybe sleep on it?

I'm sure it's a great deal for someone.

Good luck.

David
1986 GTV-6
 

·
Registered
Joined
·
95 Posts
Discussion Starter #3
Slew...you have no idea how sad I am ...but i have hit wall after wall and it's no more fun...someone else who knows Alfa better than me will have better luck...

If no one buys it, I will still try to figure it out.....
 

·
Registered
Joined
·
625 Posts
have you tried putting the engine on an engine dyno and troubleshooting it that way, as opposed to in the car? Also what ECU are you running, maybe another brand?
 

·
Registered
Joined
·
95 Posts
Discussion Starter #5
It's not the engine as i have exactly the same problem with two different engines....

It's not spark as that system was entirely replaced with a stand-alone system

It's not injector control as that system was entirely replaced with a stand-alone system, too..

Only thing left is fuel pressure/pump circuit....will hard wire to battery today and see what happens....
 

·
Registered
Joined
·
61 Posts
When you swapped the engine did you take any parts off the engine that came out? Maybe a bad part got migrated to the new engine? I'd also check all the grounds to make sure they are tight and not corroded. Have you swaped the computer yet...could be a million things and I'm sure you have looked a million times for the issue. I'll bet it's something silly and is looking you right in the face your just frustrated that you can't find it. Try troubleshooting from the beginning and toss out what you "think" you've checked...you have done too much to turn back now and admitt defeat. The car looks great!!!
 

·
Registered
Joined
·
4,075 Posts
It sounds like you have it pretty well narrowed down. If it were my car, I would replace the fuel pressure regulator and hot wire the fuel pump, via an in car on/off switch for diagnosis purposes.

Greg,
www.hiperformancestore.com
P.S. that's a cool car, I saw it in person a few years ago.
 

·
Registered
Joined
·
625 Posts
There should be some sort of diagnostic software you can plug into the ecu while testing that will record the signals and help you trace the bug. It must be some sort of dropped reference sensor or something... What car could possibly replace that one?
 

·
Registered
Joined
·
95 Posts
Discussion Starter #9
Thanks fellas! There has been some interest in the above items so I am not sure how much more I want to do.

Bosch system/ECU has no diag plug, and I have tried 3 different 3.0 ECUs and an entirely different engine w/new injectors and regulator, noid lights always worked.

May sound silly, but the only thing I have not done is hot wire the fuel pump.... it's the last thing I can think of and if it does not work, I will probably lose it!
 

·
Registered
Joined
·
625 Posts
I would think about converting to standalone such as gotech or megasquirt, then watch the curves through acceleration, find the area [about] when it sputters (not necessarily why) and then use the programmability of the ECU to counter/cover up the sputtering. By adding a reference sensor, or changing the sensor loop and how the ecu determines timing, mixture, spark, waste, etc. you might be able to fix the problem.

P.S. I like the chrome bumpers, any more pictures of them?
 

·
Registered
Joined
·
95 Posts
Discussion Starter #11
Yep...already put in a stand-alone...a Haltech 10 to run the injectors, fired right up on first try...took it on the road and had the hesitation....took out haltech and put back the Bosch control and the same thing...this was a real pain by the way..

For anyone interested: Haltech not included in sale price...going into new car...unless you want to add antoher 800
 

·
Registered
Joined
·
95 Posts
Discussion Starter #14 (Edited)
chrome: I have front and rear , front mounted only, needs some final touches...

Additional items: several sets of tailights old style including one complete brand new matching set from Re-originals; 'new' rebuilt 90 amp BMW alternator (makes everything bright!!) ; european chrome mirrors with thick stem and Alfa logo to replace electric side mirrors( was going to paint car red...and i think red goes with chrome real well); BRAND new 800 amp cold crank battery put in last week (NO trouble cranking over those 10.5:1's in freezing Michigan weather)...and much more..

sight to see and hear: Includes a short run down the street, reving the new engine, mild lumpy cam idle, and front turn signals....

YouTube - Broadcast Yourself.
 

Attachments

·
Registered
Joined
·
3,506 Posts
Rather than hot-wire the fuel pump and hope for a lack of problem, why not instrument the fuel rail and read the pressure? This would indicate when the failure occurs whether the fuel pressure is sagging. Other solutions exist.

Michael

I just realized that if I lived in MI, then I could be MIchael. I have in-laws living in the G.R. and Lansing areas.
 

·
Registered
Joined
·
1,998 Posts
xtrad.

cool looking gtv6 with the pre-black out window frame look and 2 piece tail lens. was it hard to put the older alfetta gt/spv brightwork and rain gutter in? the gtv6 rain gutters ran to the rear 3/4 vents i assume to hide the seam welds.

great lookin project, too bad you cant keep it. best of luck with your sale

D
 

·
Registered
Joined
·
95 Posts
Discussion Starter #17 (Edited)
I think I am pretty much done for now with this project......much of the chrome came with the car...It was on a real us stamp in Texas so I guess it was special at one time....
 

·
Registered
Joined
·
95 Posts
Discussion Starter #19
Greg;

I mean 'this car was on a postage stamp' a real legit US stamp at 39cents :)

This is a one of a kind Alfa....

of course I removed the black bumpers.....still have them, though
 

Attachments

1 - 20 of 38 Posts
Top