Alfa Romeo Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
Amici,

I've got 13-inch wiper blades on my 1974 GTV, which I believe is the correct size. And yet, the blades sometimes collide and jam mid-windshield, requiring me to pull over and snap them free. Not ideal on the highway during a downpour. The wiper arms are set correctly, judging by their position when they sit. And I've tried tightening the nuts that hold them in place. Any suggestions?

Walter
in Montreal
 

·
Registered
Joined
·
1,609 Posts
You could try removing one and reseting it one tooth higher. I'd go for the upper one, or move the lower one one tooth lower. That might fix your issue.

Will
 

·
Registered
Joined
·
276 Posts
Hi,

I agree with Will. The same thing happened to mine and although they sat Ok they were loose in the housings so when there was pressure on them (usually light rain when they dragged a bit) one fell behind and hit the other.

You could buy new assemblies but I just notched the lower one back one so it is almost hitting the base of the screen. They now work like a charm (with a new motor but that's another story).

I did try it the other way (top wiper higher) but it went too far off the side of the screen and risked scratching the glass. I played with it both ways until it worked well without risking damage.
 

Attachments

·
Registered
Joined
·
33 Posts
Discussion Starter #4
Plumber's tape?

Thanks for the tips, guys. It's just that I don't like the LOOK of the wiper arms when they sit too far apart. But if the problem is that the housings are loose, or that the teeth are worn, or both, I wonder: would a bit of plumber's tape wrapped around the posts do the trick by providing a snugger fit?
 

·
Registered
Joined
·
276 Posts
Hi,

It's worth a try and an experiment (aluminium foil might also work and I've got a feeling the tape might wear away after a while) before you attempt to buy new pieces that may not exist or get old ones that might be as bad as what you've already got.
 

·
Registered
Joined
·
155 Posts
The real solution is to get 11" blades from Centerline...they are correct original size The 13" are for the Berlina and Guilia Super. That is the fix and it worked for me...never a problem.
 
1 - 7 of 7 Posts
Top