Alfa Romeo Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I recently purchased a 78 spider and now the windshield wipers, head lights heater fan and brake lights are inoperative the horn and radio works the car starts and runs I have been informed that this is most likely a ground issue as I look at the schematic it shows ground points and junction boxes can any one help me locate where theses are in the car and also suggest a good electrical maintenance book i am very new to this so if this post is redundent sorry thanks
 

·
Administrator
Joined
·
17,461 Posts
Welcome to the BB! How about some pictures of your car? We likes pictures!

I'd agree that the first place to look are all the ground connections. I believe that Alfa used black wires for all the ground connections so search all over your car for any black wires and clean & tighten those. It'd probably be a good idea to remove the battery's negative cable to make sure you don't accidentally cause a short anywhere.

On our '84 Spider there are a number of ground wires up under and behind the dash, at the instruments themselves plus a gang of ground wires at the left, outside corner of the dash. Next there are various grounds in the engine bay - one or two along the top of the radiator support tend to be over-looked as they are buried under the harness running across there.

While you are at it, clean the battery terminals and cables plus the end of the negative cable where it bolts to the body.

As for books, Pat Braden's books about Alfa's are good general start. They are not specific about any particular model but they'll give you enough info that you'll have a good idea of what you are dealing with.

I have a copy of the Alfa shop manual on CD from Car Disc (<- clickable link, BTW). And it includes copies of the owner's manual, convertible top manual, TSB's, etc.

For the best possible version of a wire diagram for your car, send a PM to BB member 'PapaJam'. He'll email you a .pdf file that will make tracing wires a lot easier then the Alfa schematics. I had a local office supply store print me an 11"X14" color copy and then laminate it for less than $5.

Finally, this BB will likely be one of your best resources for help. Hang around, use the 'search' function, ask questions and you'll see what I mean. Please consider making a donation (link is at the top of the page) to keep this place alive. I assume clicking on a few of the advertising links helps, too.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
thanks

Thanks for your help here are a couple of pictures I will post more later the aero stuff is add on i may remove or not this car has twin webbers i am not sure if it was a conversion or euro spec car (Canada?) needs better side view mirror i hope the electricals can be fix easily there is no rust sound great throatyer(if that's a word) idles to slow carb prop need ajusting nexted.
 

Attachments

·
Premium Member
Joined
·
14,659 Posts
I doubt that it is a ground problem. Each of those devices has it's own ground and it is highly unlikely that they all went bad at the same time. Check the fuses first. Clean up the connections between the fuse and the brass strips that they fit into. If you leave the cover off the fuse box you can reach down and fiddle with the fuses while you are driving if the lights or the radio suddenly quit.
Ed Prytherch
74 GTV
79 Spider
88 Verde
 

·
Registered
Joined
·
2,546 Posts
mrcodydog
Welcome to the AlfaBB.
78 Spiders are great...once you get everything working!
Use the SEARCH feature at the top of the screen for finding out info from those who have been there before.

The first thing to check when experiencing electrical problems is your fuses. Under the dash to the left of the steering wheel; clean them all with some Scotchbrite or fine sandpaper. It’s not uncommon for the connections on the wiper and fan switches to be fouled up by a previous owner. Non-functioning switches are another possibility. Try spraying them internally with contact cleaner. New switches are readily available from the popular sources.

The fuse cleaning may fix your brake light problem but I have seen continuity failure within the light housing itself. Remember the car is nearly 30 years old; problems are to be expected. Complete light housings are pricey but available new or take your chances with used on eBay.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
more lost wires

on trouble shooting this problem i found that the a wire out of the alternator had come off. There is a green wire tied to a black wire that looks as if it came from the alternator but the wire diagram only shows a green wire which on is correct. see picture
 

Attachments

·
Premium Member
Joined
·
14,659 Posts
If your alternator has a built in regulator then the green wire should be connected. It makes the charging warning light work.
Ed Prytherch
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
thank for all your help the car now works only the heater fan is out most of the problems were at the fuse box it looked fine but after cleaning most of the system worked i also cleaned all the connectors i found. if any on need very large copy of the 1978 schematic i can print it 17 x 22 which is large enough to easly read i can print it larger but this is unnecessary unless you need large print to read i would send the 17 x 22 free unless i become inundated with request
 
1 - 8 of 8 Posts
Top