Alfa Romeo Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter #1
Hi all, currently i have a problem with my serie 3 33 central lock and courtesy lamps. When i open the car doors, any of them the lamp will not light up, the roof clock switches off, when i close back the door, the clock switches back on, the lamp can get on but the central lock make a buzzing sound that comes from the relay under the steering(grey box) and the fuse is burnt. when it began to do it, it did didnt do it always, soemtimes i just shaked the wires a bit and everythign was back to normal. now it seems to be permanent, i changed the grey relay box of the central lock but all in vain. i noticed but that the fuse doesnt get burnt and i checked it and it seems that there is no current passing to the fuse(you cant see smal sparks when u try to put on the fuse). is there any other device before the fuse box, or, has it happened to someone? what should i do?:confused::confused:
 

·
Registered
Joined
·
755 Posts
I had a similar problem with my interior light. Was sitting in my car with the door open and the light went out along with the clock. I checked everything and then discovered a bad earth connection under the bonnet. Fixed it up and its been fine since. Perhaps it just an earthing issue?:rolleyes:
 

·
Registered
Joined
·
755 Posts
well your car may be slightly different, but just in front of my battery there are a whole lot of them that attach to one point on the firewall just behind the engine. All the wires going to it are black. Your car being a series 3, and LHD might be different though. But look out for any black wire connecting to the chassis...probably worth inspecting it anyways to minimise issues down the road.
 

·
Registered
Joined
·
102 Posts
Discussion Starter #5
got rid of the problem, it seems to be a bad main that is going to the fuse, i did a direct main from the battery to the grey box of the central lock and it worked!;) but the interior light still doesnt get on :( to get the fuxe box out there are 2 nuts on top, to remove them you need to emove the dashboard?? because they seem to be unreacheable heh! thanks!
 

·
Registered
Joined
·
35 Posts
Watch that all positive wires go through fuses somewhere or else you risk burning your wiring. Fuses blow for a reason. good luck!
 

·
Registered
Joined
·
217 Posts
Hi,

There have been cases where the wiring passing through the pillar black snork has streched and creates wiring problems.

It is easy to remove the door card and check the wiring by moving it around simulating door opening.

Best of luck,
 

·
Registered
Joined
·
102 Posts
Discussion Starter #8 (Edited)
I know it's been a long time since i fixed the problem for the central lock, but then i forgot to emntion, that the central lock is working fine but the courtesy lamps and the clock are not working... it didnt bother me at first but now especiaally when im entering the car in the dark.. can ou please tell me what can the problem be..is there an other fusethrough the way up to the lamp and clock? thanks! btw the clock turns on when the doors are closed
 

·
Registered
Joined
·
102 Posts
Discussion Starter #9
It's me again, i followed the wiring diagram to see which is the main wire. it is a white/green wire, to avoid trouble of removing things to gain access i eliminated the door switches by cutting the wire from near the fuse box, and connecting it to a main direct from the battery, O.K. i dont have the lights on when i open the doors but at least I've got a working clock and 2 courtesy lamps( switching them on manually). :):)
 
1 - 9 of 9 Posts
Top