Alfa Romeo Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
i dont know if i can fix this on my own or if i have to find a mechanic, but i have a weird electrical problem.


occasionally my tachometer, fuel, oil pressure and thermometer, hazard lights, blinkers and dashboard lights just stop working without any warning, they also come on without warning too. there is nothing that i do that can make this not happen, it just happends out of the blue. the only thing that i can imagine is happening is that its grounding somewhere, but i dont know where. did anyone else have this problem and fixed it fast?





so this leaves me in a dilemma because i dont know how high my rpm's are, or my engine temp, im afraid to drive it because i dont know when its goin to overheat
 

·
Registered
Joined
·
145 Posts
Clean the contacts in the fuse block where the fuses make contact then replace all of the fuses. This does not cost much and most alfas need this anyway, try and use original style fuses I have run into trouble with using glass fuses because they don't fit the fuse tabs as well.
 

·
Registered
Joined
·
145 Posts
Have you tried pulling the fuse box down and pulling the wire going from the fuse box to the items that quit working? Without looking at a wiring diagram it seems to me that you have more than one circut cutting out, might also want to check the connections at the ignition swith. What year is this car?
 

·
Registered
Joined
·
9,977 Posts
Is this a "lighting" only issue or do the dash gauges themselves fail? If it's lighting only and it's a 70s spider, I'd check the dimmer switch rubbing up against the floor gear shift housing.
 
1 - 5 of 5 Posts
Top