Alfa Romeo Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
Hello

I have a bit of a problem going on in that my battery is always dead. I know its not the battery since its brand new, so it must be another issue. I just recently purchased the car so I'm still learning about it. The fuse box cover is missing so I don't know which fuse goes where. Is there anyone that might have 1) the order of what fuse does what and 2) an electrical diagram (maybe in pdf format) for the car. Your help and guidance is much appreciated.
 

·
Premium Member
Joined
·
801 Posts
On the boatails there is very little that is switched on and off with the ignition switch. Mainly juice to the coil and starter motor when in start mode. So everything else has to be switched off. Heater blower motor stays on if switched on. You have to have good ears to hear it running sometimes. Brake lights switch can hang on and if you don't notice the lights burning can drain the battery over night. On later spiders the ignition switch keeps a hot lead to the stereo system until the key is removed. Check your stereo system if you have one and make sure it switchs off (if you have one) Also you courtesy light. IN the mirror on most 69s. Just a few thoughts.
 

·
Registered
Joined
·
116 Posts
you need to see what the draw or load (amps)is with all things off. u should have less than 300 ma this car should have less than 100 ma (radio draw). next you shuld check the charging system for charging out put. how soon does the batt go dead? check the charging output as it may not be charging under load. good luck
 
1 - 4 of 4 Posts
Top