Alfa Romeo Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
Hi i have a problem with crank sensor but encountering a bigger problem finding a new one can anyone help or have a solution to fit a later type to this engine .
Mick.
 

·
Premium Member
Joined
·
26,996 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #3
hi thanks for link but these i believe are for the later engine mine has the sensor head as part of an aluminium cast bracket.
mick
 

·
Premium Member
Joined
·
26,996 Posts
hi thanks for link but these i believe are for the later engine mine has the sensor head as part of an aluminium cast bracket.
mick
Just remove old sensor from bracket and insert new sensor into aluminum bracket they are all that way since 1987.
 

·
Premium Member
Joined
·
26,996 Posts
hi thanks for link but these i believe are for the later engine mine has the sensor head as part of an aluminium cast bracket.
mick
Just remove allen head screw and remove old sensor from aluminum bracket and insert new sensor into that aluminum bracket that is held to engine with two allen head screws. They have all been that way since 1987 on 12v and 24v engines.
 

·
Registered
Joined
·
1,785 Posts
I can't say everyone runs into this, but proceed with caution when removing that little Allen head bolt. Mine came out, but it was way over tightened. Without the 3/8 drive Allen head bit that I ran out to buy, I think I likely would have rounded it out with a standard Allen wrench, as well as the long Allen driver with rounded type head. That bit seemed like it started to twist.
 

·
Premium Member
Joined
·
9,776 Posts
Hi i have a problem with crank sensor but encountering a bigger problem finding a new one can anyone help or have a solution to fit a later type to this engine .
Mick.
All the same sensor. One of ebay should work just fine
 
1 - 8 of 8 Posts
Top