Alfa Romeo Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
359 Posts
Discussion Starter #1
Hi all, been trying to get to the bottom of this one for a long time - I've set the mixture screws for the best idle but no2 choke screw makes no difference at all, you can screw it and out all day but it runs just the same, tickovers a bit lumpy but OK and out on the road its fine apart from hot traffic where it gets a bit lumpy, I've checked all round for air leaks but cant find any, on the emissions it runs rich with all the screws set for smoothest idle, had the carbs apart but cant see anything obvious although recently I've noticed a smear of fuel round the top of no2, -anyone any ideas? thanks
 

·
Registered
Joined
·
1,140 Posts
Remove idle jet and mixture screw.
There is a small port near the top,where the idle jet fits.
With a can of carby cleaner with a plastic extension,squirt down this hole and fluid should come out of the mixture screw hole.
Then apply compressed air down the idle hole port and it should come out the mixture screw hole.
Apply air down the mixture screw hole and it should come out of the idle jet hole.
This is to verify its not blocked.
Also check to see if the idle jet bottom hole is blocked or restricted.
While turning mixture screw with engine running,,remove spark plug leed to see if that cylinder is firing.
Best start with a new spark plug.
Another cause could be tappet clearance issue on that cylinder
Another cause could be bent throttle shaft
With the engine idleing,,you could also squirt carby cleaner around carby and inlet manifold to verify an air leak.If the revs change= air leak.
 

·
Premium Member
Joined
·
13,993 Posts
In addition to the above, if the idle speed adjustment has been increased to compensate for another issue (example - insufficient ignition advance) then the idle mixture screws have less influence as the first progression hole is partially uncovered.
 

·
Registered
Joined
·
359 Posts
Discussion Starter #5
All sorted, took tops off carbs, fitted new float valves as one of them was leaking a bit, reset the float height as mine has the early 10gm ones, cleaned all the passages with carb cleaner and compressed air and started fine, mixture screw works now, will fine tune and balance them today
 
1 - 5 of 5 Posts
Top