Alfa Romeo Forums banner

1 - 11 of 11 Posts

·
Premium Member
Joined
·
263 Posts
Discussion Starter #1
Can anyone tell me how to test my crankshaft position sensor to determine if it is functioning correctly? Thanks in advance
 

·
Premium Member
Joined
·
263 Posts
Discussion Starter #3
Sam,

Is the sensor testing procedure the same for a Motronic ECU? The '90 has the series 4 engine and ECU
 

·
Registered
Joined
·
1,430 Posts
Sorry, did not look at the year of your spider in your signature.
 

·
Premium Member
Joined
·
27,320 Posts
Same sensor as 164 on Motronic spiders.

Test is for .6 kohm between center pin and one outside pin. Other (third) outside pin to center pin is no reading.
 

·
Premium Member
Joined
·
263 Posts
Discussion Starter #7
Steve,

.6k ohms = 600 ohms correct? I tested my crankshaft postion sensor and got a reading of 540 ohms. Given meter accuracy this seems close enough. What do you think?
 

·
Administrator
Joined
·
17,464 Posts
My guess is that reading is OK.

Keeping in mind I know little about Motronic, is not the position of the crank sensor important? Most such systems require the sensor be positioned correctly in relation to the crank pulley (specifically the 'teeth' the sensor senses). Does the manual give you an 'air gap' setting to check or adjust? Or is just plug & play?
 

·
Premium Member
Joined
·
263 Posts
Discussion Starter #9
It appears to be 'plug & play'
 

·
Premium Member
Joined
·
263 Posts
Discussion Starter #11
1 - 11 of 11 Posts
Top