Alfa Romeo Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter #1
The Solex carburetor on my Giulia 1300 TI has been changed, and now it fouls the plug if I open the throttle too wide. I think this may be because the main jet is incorrect. I don't have the original carburetor any more, and in any case it was changed because of perfidious internal modifications by a PO.

I don't have the technical data or workshop manual for this car - can someone please point to a downloadable copy? Or alternatively, can someone please tell me what the correct jet sizes are?

I understand that some folk have had trouble tuning these engines to eliminate stumbling and flat spots. Any specific clues would be welcome.

In addition, this very nice car is up for sale (in Melbourne). It's in exceptionally original condition, with all boot floor mats intact and all original parts (except for point-less CDI), etc, and has never been in a major prang - a couple of little repairs here and there but it's been very well kept. I want to get this carburetor problem fixed first though, as it was such a sweet car to drive when it was running well.
 

·
Registered
Joined
·
1,795 Posts
A Rolls Royce Viper turbo main jet should get this rolling fairly well. But seriously, my bike did that when it's enrichment 'choke' was misadjusted. Do you suppose that might be it?
 

·
Registered
Joined
·
133 Posts
Discussion Starter #8 (Edited)
Jim, Best if you PM or email me. An email address is on the website listed in my profile, as is a phone number.

RC: Anything is possible, but Corrado Mauceri has spent some time on this carbie. I'm just doing some background research before deciding to take it back there. It runs fine at cruise, and in light acceleration, it's only when you open it up that it starts being a problem. Does that match your bike's pattern?
 

·
Registered
Joined
·
1,795 Posts
RC: Anything is possible, but Corrado Mauceri has spent some time on this carbie. I'm just doing some background research before deciding to take it back there. It runs fine at cruise, and in light acceleration, it's only when you open it up that it starts being a problem. Does that match your bike's pattern?
Actually, no. Mine was one of two carbs all the time. I does sound like a main jet if at full open only.
 

·
Registered
Joined
·
133 Posts
Discussion Starter #10
Well, that'd be the problem then. The main jet was a 160. When I can get a replacement, a bit of tweaking should have it all working beautifully again.
 

·
Registered
Joined
·
133 Posts
Discussion Starter #11
Sweet as! The replacement carbie is the slightly larger Solex, which takes a 130 main jet, so we fitted one, and the car is running perfectly. Hmm, maybe I can persuade the wife we should keep it as well as my coupe :)
 
1 - 12 of 12 Posts
Top