Alfa Romeo Forums banner

1 - 3 of 3 Posts

·
Premium Member
Joined
·
263 Posts
Discussion Starter #1
I am preparing a 1750 for use in a GTV after 7 years of dormancy. After heater box/all hoses installed I filled the radiator almost full with coolant and came back next day to small puddles of coolant under car. I rechecked all hoses, inspected radiator for leak source(none found), checked tightness of water pump mounting nuts and instrument cable, and replaced lost coolant. Upon next inspection found much less leakage/puddle under car but still some. Need advice on next steps to take. The motor has not yet been run, only turned by hand. Can water pump gasket be failing due to age? Will it swell and seal with use? Inspecting the edges of gasket and material dose not appear to be torn or ragged and also difficult to see sign of moisture around flange. Only spot showing some moisture is where instrument cable attaches.

Thanks for any assistance!
 

·
Registered
Joined
·
6,808 Posts
Best to test the coolant system with a tool that presurizes the system. Then you will be able to see the leaks.
You may be able to rent one or borrow from a friend.
 

·
Registered
Joined
·
447 Posts
1750S-
Cooling system pressure testers are available for rent at your friendly neighborhood O'Rielly's Auto Supply, AutoZone, etc. Pay the full price for the tool up front (at time of rental), return the tool within the allotted rental period after use, and you are refunded your money in full. Essentially use of the tool is free- they're hoping you will buy some parts from them......even if it is an Alfa.
 
1 - 3 of 3 Posts
Top