Alfa Romeo Forums banner

21 - 40 of 43 Posts

·
But Mad North-Northwest
Joined
·
9,863 Posts
It’s something on your system, Ruedi. Works fine for me on multiple devices, and much more usable than their old site.
 

·
Registered
Joined
·
1,767 Posts
Great info, thank you. Could you do me a favor and please check in your browser console if the JSON file loads on your VM and/or how long it takes to load? I have a suspicion there may be a regional timeout or availability issue of this file (the PNG gets loaded from an edge network, but the JSON supposedly comes from their own server).
Screenshot attached.

Geoscreenshot.com is a good site for testing a web page from different vantage points. Right now it's showing it load correctly from Bengaluru (India), Singapore and Santa Clara (California). There is a Vancouver option but you have to sign up to get it.

https://www.geoscreenshot.com/capture
 

Attachments

·
Registered
Joined
·
9,241 Posts
Discussion Starter #23 (Edited)
Screenshot attached.

Geoscreenshot.com is a good site for testing a web page from different vantage points. Right now it's showing it load correctly from Bengaluru (India), Singapore and Santa Clara (California). There is a Vancouver option but you have to sign up to get it.

https://www.geoscreenshot.com/capture
Super, thank you -- this is a great tool! The screenshot below (using servers in Toronto and Vancouver) shows the issue is a regional (geographic), technical content delivery problem.

Let's hope it's temporary, but one way or the other: The root of end user problems like this is still poor website design.

Screenshot 2019-08-26 13.08.43 (cropped).jpg
 

·
Registered
Joined
·
6 Posts
I was on here yesterday looking to price parts and functionally worked fine for me. Also kind of liked the design but that may just be me.
 

·
Registered
Joined
·
777 Posts
I don't know if any of you have seen the new Classic Alfa web site. I think it's the worst web site ever -- unusable in Chrome and Firefox on desktop and Android!!! Good on them for making it hard to place an order.

The bottom of the says "Website designed by BA Creative" -- the crappy Classic Alfa web site makes it clear that this is a design company to stay away from.
Maybe they 'Classic Alfa' don't understand how people search for car parts and or the BA Creative company does not understand either.
 

·
Registered
Joined
·
9,241 Posts
Discussion Starter #27
Maybe they 'Classic Alfa' don't understand how people search for car parts and or the BA Creative company does not understand either.
Partially correct. The core issue is that their home page not working for everybody everywhere across the globe all the time. It's a flaw in how the web site delivers content. Classic Alfa got bamboozled by BA Creative. They didn't even care to forward traffic from the old domain classicalfa.co.uk to the new domain classicalfa.com. As a result, Classic Alfa will lose business not because of the services they provide, but because of the services they were provided.
 

·
Registered
Joined
·
9,241 Posts
Discussion Starter #28
I was on here yesterday looking to price parts and functionally worked fine for me. Also kind of liked the design but that may just be me.
If you scroll back through the thread, you'll learn that it works in some regions but not in others (like mine).
 

·
Registered
Joined
·
3,681 Posts
Ruedi,

The Classic Alfa site works too well for me! Yet another batch of Duetto restoration parts on their way. Just think of how much money you must be saving...

Mark
 

·
Registered
Joined
·
2,676 Posts
Works perfectly for me on safari, chrome and Firefox. I dream/browse it a few times a week and it hasn’t glitched for me.
 

·
Premium Member
Joined
·
5,442 Posts
I've not had any functional problems with the new site but there are a few things that i wish were different:

The banner and footer take up way too much real estate. Should at least have the option to increase the number of items per page.

The old site allowed you to pick multiple items on a page before going to the cart. I don't like having to bounce back and forth for each item.

The checkout process seems unnecessarily clunky.

That said, still the best site of all the online Alfa stores.
 

·
Premium Member
Joined
·
293 Posts
Works fine for me on Safari and Firefox.
 

·
Registered
Joined
·
9,241 Posts
Discussion Starter #33
Still the same (unusable) as in the screen shots I posted above. In effect, that's a regional outage of more than 24 hours.
 

·
Registered
Joined
·
5 Posts
Hi I am the owner of BA Creative the web design agency that built the Classic Alfa website.

I am sorry to hear that you are experience problems with the site Ruedi. It does seem to be a very localised issue that you are experiencing as the website itself is working correctly.

The site has been built on an ecommerce platform called BigCommerce that uses the Google Cloud Network to deliver content. We think that there may be localised issue with this network. We're looking into it.

Thanks everyone for your positive comments about the site. As a classic Alfa owner myself it was very important that we built a site that Alfisti would love to use.
 

·
Registered
Joined
·
24 Posts
Just an FYI. I’m located in Calgary, AB Canada (~1000km from Vancouver) and I have the same issues with the website as Ruedi. Unuseable in current form for me on my laptop.

Thanks,
Julian
 

·
Registered
Joined
·
9,241 Posts
Discussion Starter #36 (Edited)
Hi I am the owner of BA Creative the web design agency that built the Classic Alfa website.

I am sorry to hear that you are experience problems with the site Ruedi. It does seem to be a very localised issue that you are experiencing as the website itself is working correctly.

The site has been built on an ecommerce platform called BigCommerce that uses the Google Cloud Network to deliver content. We think that there may be localised issue with this network. We're looking into it.

Thanks everyone for your positive comments about the site. As a classic Alfa owner myself it was very important that we built a site that Alfisti would love to use.
Thanks for chiming in, Pete!

I think you notion that "the website itself is working correctly" is misguided -- and certainly not my experience. It's the equivalent of ordering food in a restaurant, but the food does not arrive, and then trying to argue that everything is OK with the restaurant but that there's something wrong with the table the patron is sitting at (the so-called localized problem). The point is that the whole thing isn't working for me, and that's a result of how the web site is designed and delivered.

Anyhow, FWIW, here are 2 code snippets from the page source code that may help to track down the problem:

Code:
<!DOCTYPE html>
<html class="no-js" lang="en">
    <head>
        <title>Classic Alfa | UK Largest Classic Alfa Romeo Parts Online</title>
        <meta name="description" content="Buy quality parts for your beloved classic Alfa Romeos online. We are UK's largest supplier for classic Alfa Romeos parts. Ship worldwide. "><link rel='canonical' href='https://classicalfa.com/' />
        
         
        <link href="https://cdn11.bigcommerce.com/s-bgee696hg0/product_images/favicon.png?t=1528255675" rel="shortcut icon">
        <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
        <link data-stencil-stylesheet href="https://cdn11.bigcommerce.com/s-bgee696hg0/stencil/c8df2330-a5d0-0137-820f-0242ac110010/e/c63ee870-6574-0137-680b-0242ac110013/css/theme-c9097f30-a5d0-0137-820f-0242ac110010.css" rel="stylesheet">
        <link href="https://fonts.googleapis.com/css?family=Oswald:300|Open:Sans|Lato:800|Montserrat:400|Karla:400&display=swap" rel="stylesheet">
        <script type="text/javascript" src="https://cdn11.bigcommerce.com/s-bgee696hg0/stencil/c8df2330-a5d0-0137-820f-0242ac110010/e/c63ee870-6574-0137-680b-0242ac110013/js/stencil-utils.min.js"></script>
        <script type="text/javascript" src="https://cdn11.bigcommerce.com/s-bgee696hg0/stencil/c8df2330-a5d0-0137-820f-0242ac110010/e/c63ee870-6574-0137-680b-0242ac110013/js/modernizr-custom.js"></script>
        <script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/jquery/1.12.4/jquery.min.js"></script>
        <script type="text/javascript" src="https://cdn11.bigcommerce.com/s-bgee696hg0/stencil/c8df2330-a5d0-0137-820f-0242ac110010/e/c63ee870-6574-0137-680b-0242ac110013/js/instafeed.js"></script>
Code:
        <link rel="apple-touch-icon" sizes="57x57" href="https://cdn11.bigcommerce.com/s-bgee696hg0/stencil/c8df2330-a5d0-0137-820f-0242ac110010/e/c63ee870-6574-0137-680b-0242ac110013/img/apple-icon-57x57.png">
        <link rel="apple-touch-icon" sizes="60x60" href="https://cdn11.bigcommerce.com/s-bgee696hg0/stencil/c8df2330-a5d0-0137-820f-0242ac110010/e/c63ee870-6574-0137-680b-0242ac110013/img/apple-icon-60x60.png">
        <link rel="apple-touch-icon" sizes="72x72" href="https://cdn11.bigcommerce.com/s-bgee696hg0/stencil/c8df2330-a5d0-0137-820f-0242ac110010/e/c63ee870-6574-0137-680b-0242ac110013/img/apple-icon-72x72.png">
        <link rel="apple-touch-icon" sizes="76x76" href="https://cdn11.bigcommerce.com/s-bgee696hg0/stencil/c8df2330-a5d0-0137-820f-0242ac110010/e/c63ee870-6574-0137-680b-0242ac110013/img/apple-icon-76x76.png">
        <link rel="apple-touch-icon" sizes="114x114" href="https://cdn11.bigcommerce.com/s-bgee696hg0/stencil/c8df2330-a5d0-0137-820f-0242ac110010/e/c63ee870-6574-0137-680b-0242ac110013/img/apple-icon-114x114.png">
        <link rel="apple-touch-icon" sizes="120x120" href="https://cdn11.bigcommerce.com/s-bgee696hg0/stencil/c8df2330-a5d0-0137-820f-0242ac110010/e/c63ee870-6574-0137-680b-0242ac110013/img/apple-icon-120x120.png">
        <link rel="apple-touch-icon" sizes="144x144" href="https://cdn11.bigcommerce.com/s-bgee696hg0/stencil/c8df2330-a5d0-0137-820f-0242ac110010/e/c63ee870-6574-0137-680b-0242ac110013/img/apple-icon-144x144.png">
        <link rel="apple-touch-icon" sizes="152x152" href="https://cdn11.bigcommerce.com/s-bgee696hg0/stencil/c8df2330-a5d0-0137-820f-0242ac110010/e/c63ee870-6574-0137-680b-0242ac110013/img/apple-icon-152x152.png">
        <link rel="apple-touch-icon" sizes="180x180" href="https://cdn11.bigcommerce.com/s-bgee696hg0/stencil/c8df2330-a5d0-0137-820f-0242ac110010/e/c63ee870-6574-0137-680b-0242ac110013/img/apple-icon-180x180.png">
        <link rel="icon" type="image/png" sizes="192x192"  href="https://cdn11.bigcommerce.com/s-bgee696hg0/stencil/c8df2330-a5d0-0137-820f-0242ac110010/e/c63ee870-6574-0137-680b-0242ac110013/img/android-icon-192x192.png">
        <link rel="icon" type="image/png" sizes="32x32" href="https://cdn11.bigcommerce.com/s-bgee696hg0/stencil/c8df2330-a5d0-0137-820f-0242ac110010/e/c63ee870-6574-0137-680b-0242ac110013/img/favicon-32x32.png">
        <link rel="icon" type="image/png" sizes="96x96" href="https://cdn11.bigcommerce.com/s-bgee696hg0/stencil/c8df2330-a5d0-0137-820f-0242ac110010/e/c63ee870-6574-0137-680b-0242ac110013/img/favicon-96x96.png">
        <link rel="icon" type="image/png" sizes="16x16" href="https://cdn11.bigcommerce.com/s-bgee696hg0/stencil/c8df2330-a5d0-0137-820f-0242ac110010/e/c63ee870-6574-0137-680b-0242ac110013/img/favicon-16x16.png">
        <link rel="manifest" href="/manifest.json">
        <meta name="msapplication-TileColor" content="#ffffff">
        <meta name="msapplication-TileImage" content="/ms-icon-144x144.png">
        <meta name="theme-color" content="#ffffff">
        <link href="https://fonts.googleapis.com/css?family=Montserrat:400,600" rel="stylesheet">
I can confirm that the navigation icons seem to load (with the exception of icon-contact.png) but they are not used on the displayed page. The browser console keeps showing a coding error (which I believe may be triggered either by the missing manifest.json or the custom.js on cdn11.bigcommerce.com being out of sync).

Code:
jquery-3.4.1.min.js:2 jQuery.Deferred exception: e.indexOf is not a function TypeError: e.indexOf is not a function
    at k.fn.init.k.fn.load (https://code.jquery.com/jquery-3.4.1.min.js:2:83689)
    at HTMLDocument.<anonymous> (https://cdn11.bigcommerce.com/s-bgee696hg0/stencil/c8df2330-a5d0-0137-820f-0242ac110010/e/c63ee870-6574-0137-680b-0242ac110013/js/custom.js:52:22)
    at e (https://code.jquery.com/jquery-3.4.1.min.js:2:29453)
    at t (https://code.jquery.com/jquery-3.4.1.min.js:2:29755) undefined

jquery-3.4.1.min.js:2 Uncaught TypeError: e.indexOf is not a function
    at k.fn.init.k.fn.load (jquery-3.4.1.min.js:2)
    at HTMLDocument.<anonymous> (custom.js:52)
    at e (jquery-3.4.1.min.js:2)
    at t (jquery-3.4.1.min.js:2)
 

·
Registered
Joined
·
231 Posts
While I like CA's old website better, I have not had any trouble using the new one (Chrome, 3 different computers).

As has been noted above, their service and prices continue to be outstanding.

While we are on this subject, Vick's also changed their website, which I find to be terrible.
 

·
Registered
Joined
·
9,241 Posts
Discussion Starter #38
The Classic Alfa web site currently seems to be working in Vancouver, BC, but the manifest.json error is still there.

Do I trust Classic Alfa web site will be there next time I try it? Not a single bit.
 

·
Registered
Joined
·
5 Posts
Good to hear that the website is working again for you Ruedi.

The issue appears to have been related to caching on a part of the BigCommerce content delivery network. They have cleared the cache and that has resolved the issue.
 
21 - 40 of 43 Posts
Top