Alfa Romeo Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
204 Posts
Discussion Starter #1
Hello members of this vast knowledge bank,
I have an on again, off again check engine light. Codes are currently 1223 and 1224. Had a 1225 last week, but gone now. Checked intake hose and found some minor cracking that I covered with silicone. Have a new hose on the way. What else should I check? Also, where are the O2 sensor wires usually located? I can't find them on the transmission side.

Tom
 

·
Registered
Joined
·
204 Posts
Discussion Starter #2
Forgot to say that the car runs well, but it smells rich at the tailpipe.
 

·
Premium Member
Joined
·
27,377 Posts
O2 sensor wires connector(s) depending on whether car is 12v or 24v V6 are in area of throttle cable under big black intake hose. Two connectors on 12v - one spade connector in a rubber boot for sensor and one Bosch two wire connector for sensor heater. On 24v one 4-wire Bosch connector.

Sound like sensor not able to lean out mixture. O2 sensor maybe actually bad or maybe hidden coolant temp sensor in mid thermostat housing or wires to it has high resistance when hot. It can be bad without getting a 1214 code.

Code 1225 is for engine air temp sensor in air flow meter. You can check resistance between pins 4 and 5 if car is a 164B/L or 24v model but on S AFM only has 4 pins.
 

·
Registered
Joined
·
204 Posts
Discussion Starter #4
Thanks Steve! It's a 1991 L, 381,000 miles. Will get on it this weekend.
 
1 - 4 of 4 Posts
Top