Alfa Romeo Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
hi everyone.
this is my first post but i ve been referring to this forum for advice and knowledge for a long time now.
but now i have a problem that i can t seem to work out.

the car is a 1977 alfetta gtv fitted with a 1st gen 1.8 turbo motor and a mix of drivetrain/suspension from the 75 and the gtv6.
the car uses two fuel pumps.in tank and under the car.less than a year and 2000k ago the fuel filter,the injectors,and both pumps where changed.the in tank seems to be the same as on some vw s and i used that cause it was there and the external bought new but not oem.
they worked fine until a couple of weeks ago.
when i drive for more than 20 minutes and everything comes to working temp there is a buzzing noise like a wasp being trapped in the tank.
i thought of the high pressure external pump but when i go near i can t hear anything.when i open the rear hutch is loud.
the problem is i thought the in tank couldn t be heard because of its low pressure.
the thing is that it s difficult to change cause i have to get the tank out,again,so i would appreciate any thoughts before i start all over again.
thank you
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
one more thing that came to mind.
the fuel gauge won t always work.i can t seem to find a pattern for this.
the sender is the lever arm thing from alfetta gt? possibly because now the tank is deeper and when it goes to empty i still have around 15 litres of fuel.so i keep her topped.don t know if it s relevant.
 
1 - 2 of 2 Posts
Top