Alfa Romeo Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter #1
Anybody know what to do about a broken cable, drivers side power window on my 87 Milano Gold? I got the mechanism out but dont see an easy fix.
 

·
Premium Member
Joined
·
291 Posts
Anybody know what to do about a broken cable, drivers side power window on my 87 Milano Gold? I got the mechanism out but dont see an easy fix.
Well, I didn't see an easy / feasible fix last year for my '88 Verde either. Ended up buying a replacement mechanism from IAP, which works fine. It's just a drop-in fit, so no messing around. But I kept the original mechanism, just in case a big inspiration hit some day.
Jim
 

·
Registered
Joined
·
99 Posts
Discussion Starter #3
Thanks. IAP has it listed but out of stock. I did find a used one locally so will probably do that.
 

·
Registered
Joined
·
2,984 Posts
I got a new one from vicks not to long ago. at not bad of price. $140
http://www.vickauto.com/

seems beter then puting one in that is just about to go.
I have had the gears go on 2 so far. never had the cable snap

check that the window goes the right way before you put the door all back.
when I did the last one I must have pluged it in the wrong way now up is down and down is up.
and I have not wanted to open the door again.
 

·
Registered
Joined
·
3,771 Posts
I have a used mechanism from my parts car. It's the sturdy old school type with the metal motor surround. I had a window mechanism break at 100K on my Verde and replaced it with this type and haven't had problems so far.

I can send it out to you for $45 shipped if you decide to buy used instead of new.

Thanks!
 

·
Registered
Joined
·
9 Posts
I had this problem on my GTV6 a few years ago. The motor worked, but the cable had snapped. I just went to a chandlers and bought a length of cable plus stop ends and would it around the drum/ pulleys, and it has workse dfine since. Total cost was about £10.

Hope this helps!
 

·
Registered
Joined
·
99 Posts
Discussion Starter #7
Thanks all for advice and offers. Found a good used one at the Alfa shop and installed it in under 30 min - so far works fine. Now the fun part of putting the panel back with a few broken snaps.
 
1 - 7 of 7 Posts
Top