Alfa Romeo Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi, i've been attached to this forum for the past few days..so happy i stumbled on this gem..it has only fed my desires to learn more about my purchase. I treated myself to an '81 alfa spider in great shape..no rust..80k miles..i hope to restore the top this winter...although some questions have already been answered and more are sure to come..here's the top of the list;
a. my car idles very high upon ignition..and settles down after 1-2 minutes (tach is not functioning but i'd guess at about 3000-4000rpm)..why is this??
b. it also runs with very low oil pressure..probably hovering around or below the 1/4 level..the gauge could be faulty..but the temp. gauge and fuel gauge work fine.. any tips on what i could check or do to remedy?

Thanks to all in advance..
johnny g.
long time alfa enthusiast
newest alfa owner
 

·
Administrator
Joined
·
16,626 Posts
Welcome to the BB. How about some pictures of your Spider? We likes pictures.

Use the search function in the Spider section of the BB to find some great posts about replacing the top.

a) Scroll down the BB's main page to the 'Carbs & FI' section for a couple of sticky posts about the SPICA FI system.

b) It is common for oil pressure to read quite low with warm oil at idle. What does the gauge read at higher rpm's - say 2000 or 3000 rpm. Should be at least 50 - 60 psi then. (Afa gauges aren't the most accurate...)
 

·
Registered
Joined
·
2,068 Posts
the oil pressure senders also have a bad reputation. the sender is under the intake just above the starter. I would verify the pressure with a mechanical guage, just in case the pressure is really low. the oil pressure light comes on somewhere around 7 psi. it should light when you turn the key on and go foo while cranking.
cliff
 

·
Registered
Joined
·
4,042 Posts
Welcome

Hi Johnny,

Welcome aboard, the BB is a wonderful place to find out whatever you want to know about your Alfa. Becareful though you may find yourself spending all your free time here and some have been know to come here when their at work too. :D
 

·
Registered
Joined
·
9,977 Posts
The fast idle might possibly be due to a bad thermostatic actuator in the fuel injection system. Are you planning on doing your own mechanical work. If so and you want some Spica tech material, PM me an email address capable of receiving some large files.
 
1 - 5 of 5 Posts
Top