Alfa Romeo Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
428 Posts
Discussion Starter #1
Dear Listers:
Today my 88 Spider's clutch wouldn't engage, and upon closer inspection on the rack, I saw that the entire bell housing is cracked and split, so that when i push-in the clutch it actually extends the bell housing (!) About the LAST thing in that system I thought would ever break,
My question, can I buy the bell housing separately or do I need the whole transmission? AND if I need the whole transmission, does anyone have one cheap in the SF area?
Thanks much and
Cheers
Andy
P.S. Until today, car had just completed 2200-mile trek from Bay Area to Vancouver, Canada without a single hitch. Even got 30 mpg on one leg!
 

·
Registered
Joined
·
6,690 Posts
I bought a '69 Berlina with the same problem. Was told that it can happen if there is no front brace on the larger starter.
You should be able to replace just the bell housing. I'm sure that APE has a truck load of them!
 

·
Registered
Joined
·
2,513 Posts
Dear Listers:
Today my 88 Spider's clutch wouldn't engage, and upon closer inspection on the rack, I saw that the entire bell housing is cracked and split, so that when i push-in the clutch it actually extends the bell housing (!) About the LAST thing in that system I thought would ever break,
My question, can I buy the bell housing separately or do I need the whole transmission? AND if I need the whole transmission, does anyone have one cheap in the SF area?
Thanks much and
Cheers
Andy
P.S. Until today, car had just completed 2200-mile trek from Bay Area to Vancouver, Canada without a single hitch. Even got 30 mpg on one leg!
If you can get the bellhousing out to me, I can weld it back together for you, yes, I know cast aluminum is a pain, but we've got aluminum stick and mig welders at work set up just for aluminum, pm me if interested, no, I won't charge you. Just pay shipping for both ways and donate $20 to the alfabb.
 

·
Registered
Joined
·
428 Posts
Discussion Starter #4
Thanks

you guys are great! thanks for the good information and the kind offer. I will see which route is the most expeditious when I talk to my mechanic tomorrow. Thanks
Cheers
Andy
 

·
Registered
Joined
·
428 Posts
Discussion Starter #5
cracked bell housing caused by missing front brace? 88 Spider Veloce

Hi Listers:
When I reported on the cracked bell housing on my transmission, I got this message back from fellow lister "105 Guy":


I bought a '69 Berlina with the same problem. Was told that it can happen if there is no front brace on the larger starter.
You should be able to replace just the bell housing. I'm sure that APE has a truck load of them!

How might I ascertain that that my starter is missing a front brace OR that this model (88 Spider) even had one?
Much closer to a solution now thanks to all of you and
Cheers
Andy
 

·
Trained (ex)Professional, , 1953-2018 RIP,
Joined
·
16,232 Posts
Pic of the bracket here. Not sure if the 88s came with the bracket. I'll check the parts book in a little bit...
 

·
Trained (ex)Professional, , 1953-2018 RIP,
Joined
·
16,232 Posts
If I'm reading the microfiches correctly, 1985 was the last year for the support bracket.
 

·
1966-2013
Joined
·
13,741 Posts
Tried one spring '06 & I gaurentee it won't work on mine.

Well, it spun, (sometimes it would even turn the engine), and it tried to grind the crap out of the ring gear and bendix every time the key got turned, so I guess it 'worked' but it just didn't do it real well :D

The downside is the big motor was the only one any parts counter showed for mine including the usual suspects that I called. (actually the big-un was the only one a lot of them showed)

The upside is the one that goes on is smaller, lighter, and can be rebuilt for a song at the local Bosch shop. (WAY under what anyone else offered for rebuild service)
 
1 - 9 of 9 Posts
Top