Alfa Romeo Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
484 Posts
Discussion Starter #1
Intersting problem came up yesterday on my 91 164S. The car has been sitting for a bit as I am using my Grand Cherokee given all the snow we have had in nothern Utah. I drove it yesterday and found out that when I use the remote or the lock button on the console the lock buttons go down and pop up as if a circuit is open (ie door not closed). All the doors are closed and no open door icon on the dash panel. Any thoughts? Terry
 

·
Premium Member
1991 164L
Joined
·
27,579 Posts
Double check all doors in open position to see if all 4 icons light up.
 

·
Registered
Joined
·
596 Posts
Do you have a frozen door handle? My passenger handle sticks when it's really cold, and will keep the central locking from locking all the doors when that happens.
 

·
Registered
Joined
·
285 Posts
Strangely, my 95 is suddenly having the same problem. All doors when open register on the dash, but none are open or registering as open. Any ideas?

Mark
 

·
Premium Member
Joined
·
9,868 Posts
Intersting problem came up yesterday on my 91 164S. The car has been sitting for a bit as I am using my Grand Cherokee given all the snow we have had in nothern Utah. I drove it yesterday and found out that when I use the remote or the lock button on the console the lock buttons go down and pop up as if a circuit is open (ie door not closed). All the doors are closed and no open door icon on the dash panel. Any thoughts? Terry
Sounds like a door is slightly ajar or lock stuck due to being cold. Grab the inner door handle on all the doors and open them slowly of course and make sure they are not slightly locked. You may find one that will click open. Then close them all and try to lock it.

Jason
 

·
Premium Member
1991 164L
Joined
·
27,579 Posts
Wait for warmer weather. I had Rosso's R/F icon stay on with door closed other day when below freezing but after day warmed up back to normal.
 

·
Registered
Joined
·
285 Posts
No door icon is lit unless a door is unlocked. Temps are in mid 30s in CT today, so I am doubtful that it is part of the issue. I will try some more on "gently" opening and closing..

Thanks

Mark
 

·
Registered
Joined
·
285 Posts
My previous statements remain true. I opened all four doors and saw four icons active (four doors open). I closed each door and each related icon disappeared. I pushed the lock on the driver's door and it went down, the doors all locked and then immediately unlocked again (with the associated noises).

Any other ideas than waiting until spring?

Mark
 

·
Registered
Joined
·
484 Posts
Discussion Starter #11
Mine work properly now that it has warmed up in Utah. Of course warmed up means in the 30's! Terry
 

·
Registered
Joined
·
285 Posts
I fiddled with the passenger front door handle (exterior) when I noticed that it felt sluggish. After a few fiddles, the key now locks/unlocks the doors properly now.

Mark
 
1 - 12 of 12 Posts
Top