Alfa Romeo Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
487 Posts
Discussion Starter #1
...I touch the lead with 12 volts.

Once I start my Verde, the alternator does not seem to begin recharging. Testing the battery shows 12-12.5. It is only after I connect an alligator clip to the positive post, and touch the alternator lead can I "hear" it kick in and volts are up to 13.5 - 15.:confused:

As there an alternator light somewhere I'm missing? What else signals the alternator to start charging?
 

·
Registered
Joined
·
2,068 Posts
there is a light on the dashboard, marked "generat" i think, which lights up befor starting the engine and goes out if the alt is charging. if it burns out, or the wireing is bad, the alternator will not charge.
cliff
 

·
1966-2013
Joined
·
13,741 Posts
In the Bosch system, the size of the charge warning lamp bulb is critical. Too low a wattage bulb will not supply enough field current for "bootstrap" operation to be reliable. The Bosch book that I have states that the lamps must be at least 2 watts for 12 volt systems. If you have replaced your charge warning lamp recently, then too small a lamp may be your culprit.
Who'da thunk it.

I wonder if that's relative to some of the other folks who get the glowing light til they rap the throttle once to wake up the alternator.
 

·
1966-2013
Joined
·
13,741 Posts
papajam said:
I posted on this BB a few years
Sure, rub it in. I've only been here about 19 months and haven't even gotten through people's current posts. :D


lowmileage said:
I thought you knew everything
Yeah, don't I wish.

Actually the only thing I want to know everything about is next weeks winning lottery ticket numbers. ;)


hehe
 

·
Registered
Joined
·
5 Posts
But, where is the problem if the alternator light is on when the engine is not running, but off when the engine is running? I have checked all green wire connections and replaced the voltage regulator on my "86 spider's rebuilt Bosch alternator but haven't cured the problem.
 

·
1966-2013
Joined
·
13,741 Posts
But, where is the problem if the alternator light is on when the engine is not running, but off when the engine is running?
That's not a problem, that's what it's supposed to do.

Engine not running = no alternator output = light on telling you that the charging system isn't functioning, which it isn't because the engine isn't running and turning the alternator pulley.....
 

·
Registered
Joined
·
5 Posts
So, your alternator light stays on continuously when the car is parked with the key out of the ignition? I have never had any other car do this.
 

·
1966-2013
Joined
·
13,741 Posts
You didn't say 'key out of the ignition' you said 'not running'. (worlds of difference)

I've no idea why the light would stay on in that circumstance, or even how it could if all the wiring was correct.
 
1 - 12 of 12 Posts
Top