Alfa Romeo Forums banner

1 - 20 of 93 Posts

·
Registered
Joined
·
415 Posts
Discussion Starter #1
Ok, I get it, the owner of the AlfaBB wants the monetize the site.

And some of my problems are because I use software that protects my privacy and I try to duck advertising. Yes, I run a pi-hole and uBlock Origin. Yes, I deny third party cookies. And, Yes, I know how to whitelist things.

But NO other site I use has this many problems. And I use a good number of forums.

Fix the pictures, stop the flashing ads, and fix whatever caused all the server errors this afternoon (that one really doesn't look like my configuration.)

Frankly, the management should migrate the alfabb away from the horrible "autoguide" place.

I've been a member since 2004, and this place is a drag now. I'll be looking for a better Alfa Forum. Heck, I'd rather post on the evil FB than deal with the idiosyncrasies of this autoguide thing.

PS: I paid in the past for an upgraded membership. And I pay for some other forums I belong to. I believe in supporting web sites I appreciate. And I might consider upgrading my AlfaBB membership again. But not while all these problems persist.
 

·
Out of the office!
Joined
·
11,154 Posts

·
Registered
Joined
·
415 Posts
Discussion Starter #3
Thank you for your comments.
I am not sure what you hope to accomplish with your post. I have been off and on the AlfaBB all day and have not had any issues.
Just so you know, Autoguide=management=ownership.
Yes, it seems to be working again, possibly the server problems were just a very short term thing.

I'm not a frequent visitor anymore, and a bunch of that is because every time I visit the site is a miserable experience.

If the site really is owned by autoguide... was that always true? What a horrible shame.

Lots of GREAT people and info here, and one of the worst websites.

What do I want to accomplish? To let whoever runs the place know that I think the site is designed badly. And to let others who are frustrated know they aren't alone.

server errors
picture problems
slow loading
flashing ads
narrow pages and giant top advert space
etc.
 

·
Out of the office!
Joined
·
11,154 Posts
Yes, it seems to be working again, possibly the server problems were just a very short term thing.

I'm not a frequent visitor anymore, and a bunch of that is because every time I visit the site is a miserable experience.

If the site really is owned by autoguide... was that always true? What a horrible shame.

Lots of GREAT people and info here, and one of the worst websites.

What do I want to accomplish? To let whoever runs the place know that I think the site is designed badly. And to let others who are frustrated know they aren't alone.

server errors
picture problems
slow loading
flashing ads
narrow pages and giant top advert space
etc.
The design has not changed for as long as I can remember. The site has always used the same software, Vbulletin. I am sure there have been numerous software updates since you joined in 2004.

Other members who have not paid for a subscription don't seem to be sharing your experience or, they aren't commenting.

Paying for a subscription might just change things for you. You won't be exposed to the ads. The company that owns this site is in the business to make money. Thus, the ads.

The AlfaBB is THE place to go for information. There is no better place on the planet for help and information on classic Alfa Romeos.
 

·
Out of the office!
Joined
·
11,154 Posts
Strange...I don't see any of the issues you experience. Was this with a paid membership? When I was not with paid membership I was experiencing the pop-ups and annoying ads....but not after upgrading to a paid membership.
We are running a test to see if a subscription changes things for him. It's valid for a month. If he notices improvement in his experience, then he can purchase a subscription.
 

·
Premium Member
Joined
·
293 Posts
No problems for me.
 

·
Premium Member
Joined
·
13,061 Posts
It has been a pain for me today. Database error messages, long delays, takes several attempts to send a PM. It is a hit and miss experience.
 

·
Registered
Joined
·
440 Posts
Whatever the issues...this website provides a wealth of information and a great connection to the "Alfa Community."
My only issue is the "10 second rule." More often than not I will click an icon...and nothing appears to happen..Click again..and I'm immediately scolded about waiting 10 seconds. Try again in....
Small price to pay for such a valuable service
 

·
Premium Member
Joined
·
653 Posts
Significant technical issues have been my experience for quite some time. Overall, the value of the site clearly outweighs the trouble, but it would be nice if it worked better. BTW - I am a paid subscriber. I do use a Mac, but the problem persists with the Chrome, Safari & Firefox browsers.
 

·
Registered
Joined
·
141 Posts
The forum doesn't give me much trouble, but people who are long-time members may not appreciate that this is what ossodiseppia's signature looks like when you're not logged in. :)



Brian __________________________________
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.




To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
 

·
Registered
Joined
·
4,133 Posts
For several years now I've used an up-to-date Firefox with AdBlocker installed. This combination works exceptionally well, allowing me to, usually, log onto the site without difficulty. Occasionally, however, there are abysmally long wait-time problems. Of late these seem to occur when I link to the site from my Earthlink mail server. These are not common enough to be chronic and I attribute this to the site management's efforts to keep things running smoothly. My recommendation: use a good Ad blocker and you should be ok.

I notice that a lot of sites are turning to Ad blocker nag notices or are prohibiting access unless you also allow their cookies and ads to show. Although this appears to be a trend in internet based advertising, I'd like to urge the BB powers-that-be to avoid this at all costs. The bb has always been a unique place because of its robust user community. Retail advertising avarice can ruin things.
 

·
Premium Member
Joined
·
653 Posts
For several years now I've used an up-to-date Firefox with AdBlocker installed. This combination works exceptionally well, allowing me to, usually, log onto the site without difficulty. Occasionally, however, there are abysmally long wait-time problems. Of late these seem to occur when I link to the site from my Earthlink mail server. These are not common enough to be chronic and I attribute this to the site management's efforts to keep things running smoothly. My recommendation: use a good Ad blocker and you should be ok.

I notice that a lot of sites are turning to Ad blocker nag notices or are prohibiting access unless you also allow their cookies and ads to show. Although this appears to be a trend in internet based advertising, I'd like to urge the BB powers-that-be to avoid this at all costs. The bb has always been a unique place because of its robust user community. Retail advertising avarice can ruin things.
This prompted me to experiment a little. I opened this page using the "Brave" browser (really, that's the name of it) which intrinsically blocks all ad calls (and I think javascript, but I don't remember exactly).

The page loaded immediately (like right bloody NOW) and the browser notified my that 13 ad calls and/or trackers were blocked. Replying to this message resulted in blocking another 11. Seems like the problem is excessive and/or incompatible calls.

No idea how this works for a non-paying member.
 

·
Premium Member
Joined
·
2,600 Posts
WOW! Been on this site for over 15 years and when we transitioned I had a few issues, but they were gone in days. Are you sure you're LOGGED IN?
I get ZERO adds. BUT I've had to change my password a few times to fix some issues that come up occasionally, and that always has fix the issues I've had.
Try that?
 

·
Registered
Joined
·
415 Posts
Discussion Starter #18
The forum doesn't give me much trouble, but people who are long-time members may not appreciate that this is what ossodiseppia's signature looks like when you're not logged in. :)
Obviously, the site is a business and they want to sell subscriptions.
But I think most of the apologists have upgraded memberships and are logged in all the time, so they see fewer of the presentation problems. They may also not use other sites, so they may not understand how much smoother things could be.

I just wanted to put this thread up here. It's the comment section, and seems like the right place for it.
But I did not realize the site was wholly owned by Autoguide... so it may not be fixable. They will only really care about the money.
I really thought that when I joined the AlfaBB wasn't an Autoguide property? I have vague memories of a transition at some point.
 

·
Premium Member
Joined
·
2,600 Posts
I get Zero pop ups Zero adds, I swear!
Used many different computers, try my suggestion and write back. Use forgot my password option, you'll get a letter in 5 minutes, if you have your e-mail registered with the site and PLUNK in a new one and see what happens?

PEACE
 

·
Registered
Joined
·
74 Posts
I have been a non-paying member for one year.
I know nothing about the gizmos used to block adds or to make the site less obtrusive and I know that the owner wants to profit from the same.
But, most definitely, this site is heavy with the adverts, specially the ones that interrupt you, or pop up.
It feels like trying to work while a cloud of mosquitoes bite you.

Still, I'm going to continue to use it because of the wealth of information found here.
What I would like to know is how other forums, even bigger than this, that I belong to, manage to make money with far less distractions, that's all.


I'll consider now to become a paying member if it is true that all the problems disappear.
 
1 - 20 of 93 Posts
Top