Alfa Romeo Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
268 Posts
Discussion Starter · #1 ·
So, today I picked up the '95 164LS which I had posted about earlier.

We had it taken down to Nick Falcone's beforehand so that Alfa guru Vince could check out the potential timing belt issue. Their diagnosis was that rubbing noise on cold start was likely two factors:
1) Belt possibly torqued a bit too tight.
2) All 4 motor mounts were shot which may have been shifting things enough to cause some rubbing. Those were replaced (yikes, I forgot how costly owning an Alfa can be) and all seems well based on brief time I have had possession of car. Will keep an eye on it just to be sure.

A few observations from my first real drive. Any suggestions welcomed.

1) The test button on dash does not light up anything. All the center idiot lights between the tach and the speedo do come on when key is first turned.

2) Fuel light was on and fuel was low. I filled her up, fuel light is still on.

3) I left the manual at home but I have a bad feeling that the tilt wheel adjuster is broken / missing. I can not find it unless the wheel is not adjustable on the LS? Is there a way to fix or to at least do a one time adjustment?

4) A/C is not as cold as I think it should be. I have not measured temp at vents but seems like it should be much colder. A/C was just serviced last week as I had noticed this when I first saw the car. Shop reported a leak at expansion valve and faulty expansion valve. The expansion valve was replaced and system recharged. Looks like they did put some UV dye in there so I can check later. Any ideas?

5) Climate control display mostly not functional. I knew this before purchase but I should have also looked into cost for replacement or repair of the display (another yikes there).

6) Noticed that the fluid level sensor on the brake fluid cap has been jumpered with a piece of wire. Probably just a bad sensor in the cap but will have to address that.

I'll likely discover a few more items but she seems very clean and seems to run well otherwise. Vince looked her over on the lift and says that she is rust free, no sign of collission or paint work, very clean overall.

Let the adventure begin. I even just renewed my AROC membership which lapsed years ago! Perhaps I will see some of you at Carlisle.
 

·
Premium Member
Joined
·
6,642 Posts
welcome

quick reply

1. Test button is a weird duck. Read the ops manual; it really only does anything at initial key-on, and it doesnt light up all the icons, its an internal check for self-diagnose system really.
2. Low fuel light is a common issue, thought to be somewhat caused by ethanol in the gas acting on the sensor strip in the level sender itself. I would leave it for now
3. Tilt is a joke on LS. Theres a red tipped lever under right hand side of steering wheel, you have to get your head down by the gas pedal to see it usually. Doesn;'t tilt much! Pull that lever up towards the roof to release it -- described in the owners manual (hope you have one!)
4. Wait and see on aircon
5. I can help you with LCD -- I fix em
6. Usually bad sender in brake fluid res.

WELCOME TO THE CLUB!!!!
 

·
Registered
Joined
·
268 Posts
Discussion Starter · #3 ·
Thanks. Yes, I do have the manual, it is just not with the car at this moment.

Found the tilt wheel release lever. It does not seem to be releasing the wheel even a little. In closed position it essentially points to front of car, I can release it to where it is pointing not quite stright down to floor. Should it move more than that? Feels like there could be a wiring harness connector blocking it unless that is as far as it should go?

Hopefully no aircon problems. Of items discovered thus far, that is the only really troubling one as it is getting hot here!
 

·
Registered
Joined
·
1,046 Posts
Welcome to the group.
My LS gas guage light goes out with a full tank and starts to blink on at 3/4 and stays on , after that. I chaulk it up to a Alfa thing. None of my cars are any better.
2. Steering wheel ajustment is hard to find and when found is not very gratifying.
3. Test button - I don't use
4. A/C depends on a cool running engine check radiator effectiveness
5. brake fluid cap are available. I'd replace it.
Good luck with the motor mounts.

Frank
 
1 - 5 of 5 Posts
Top