Alfa Romeo Forums banner
81 - 87 of 87 Posts

·
Registered
Joined
·
1,072 Posts
Resurrecting this post as others may be in the same bind. I managed to find one cable (#1) but can't find #2. Does anyone have a valid link, preferably for a north American seller (don't want to wait 45-60 days) or someone have one I
1684601
1684602
can borrow?
 

·
Registered
Joined
·
1,072 Posts
Wound up buying both this morning from Canada, U.S. sources. Cost me around $32 cdn combined and should be here in 1-2 weeks versus the 45-60 day average for stuff ordered from "over there".
 

·
Registered
Joined
·
2,227 Posts
Would love to know how it goes. When I tried connecting via this stuff the ECU security warning light blinked on and were issues with signal delays. Not having a spare ECU I chickened out of doing much more and turned off. Car running fine. Lovely software readouts. Please keep us posted how your experience goes. I might become brave enough to try again.
 

·
Registered
Joined
·
909 Posts
Would love to know how it goes. When I tried connecting via this stuff the ECU security warning light blinked on and were issues with signal delays. Not having a spare ECU I chickened out of doing much more and turned off. Car running fine. Lovely software readouts. Please keep us posted how your experience goes. I might become brave enough to try again.
IIRC, it worked great for me, the software is indeed a real piece of work considering the age of our cars electronics interface. Unfortunately, even though I tried to reset airbag light, which it did erase. It came back on after some driving.
 
81 - 87 of 87 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top