Alfa Romeo Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 · (Edited)
hi, im new here,:cool: i love my spider, have been workin a lot on it.
been looking around..

But I have a problem, the windshield wipers on my 91 spider, dont work!
any tips on what to check?

if i want to check the wipers electrik motor... where can i get to it?:confused: do i have to take apart the complete interior dash? :eek:
or can i do it from de outside?
thnx!
 

·
Administrator
Joined
·
18,570 Posts
May we assume you have checked the fuses?

And indeed the wiper motor is accessed from 'outside'. You remove the cowl panel in front of the windshield to find the wiper motor. But they are quite sturdy - usually the biggest problem is the grease gets dry & hard and the wipers move slowly. So check for electrical issues first.

Anyway, looky here:

wiper motor
slow wipers
wiper tune up
cowl or air grate removal
 

·
Administrator
Joined
·
18,570 Posts
Oh, and seeing as you are a self-confessed 'new guy*' we'll forgive you for violating our unwritten rules. PICTURES! We demand pictures. Of your Spider if you gots them. If there is a pretty woman in the photo even better.

(*you are a guy, right?)
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
yes i checked the fuses. everythings ok.
gonna check under that pannel again. and take a look at that motor.

and take a look at those links also.. thanx. :D

about those pictures haha,, sure i have pics from my spider, gonna post them in a while! :cool:
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top