Alfa Romeo Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4,549 Posts
Discussion Starter #1
I was able to drive my 91 around the neighborhood the other day testing the gear box and driveability. The car passed with flying colors compared to what it was when I brought it home a few months ago.

What I noticed is that the odometer is not recording mileage. How do I isolate the problem to the sensor on the gear box to the odometer itself? Any suggestions are appreciated before I send the head off to Palo Alto Speedometer for diagnosis.

Any idea where the sensor is on the gear box? I heard it is high up but I can't see it, or am I not looking in the right place?
 

·
But Mad North-Northwest
Joined
·
9,885 Posts
If the needle works but the mileage doesn't change, the problem is in the speedo itself.
 

·
Registered
Joined
·
4,549 Posts
Discussion Starter #3
The speedometer doesn't move either. :( I was wondering if it the sender or the head, but if I got your drift, it is the sender. Now to find it and a replacement. I will be checking with my local BMW independent to see where he would source one and at what cost.
 

·
But Mad North-Northwest
Joined
·
9,885 Posts
If neither the needle or the odometer move, it could be one of three things: the cable, the sender, or the speedometer head. The latter two are both sort of dodgy, I'm afraid, and without doing some testing it's hard to tell which is the problem.

On the S4 the sender is mounted by the exhaust downpipes and I think they tend to fail from heat. Alfa Parts in Berkeley sells an aftermarket one that works, but it's not cheap. Another alternative is to buy an S3 one from APE and splice on longer wires (that's the only difference between the S3 and S4 units).
 

·
Registered
Joined
·
4,549 Posts
Discussion Starter #5
Gubi, I probably should have been more clear about which model 91 I have. I wasn't thinking that far ahead when I posted. The car is a "automatic" therefore it has no cable. It must be the sender not getting a signal to the head to move the needle. The head from what I was told by Doug is that it is a two wire affair and so is the head different, so the sender is most likely different than a 5 speed. I will crawl under there later this evening and see if I can spot the sender and check the connections etc.
 

·
But Mad North-Northwest
Joined
·
9,885 Posts
Yeah, the sender is different. The auto box has a sender in the transmission.
 

·
Registered
Joined
·
4,549 Posts
Discussion Starter #7
Gubi, There is a two wire affair on the right side high up on the trans that has a black rubber/plastic cover on it. Those two wires lead into a sheath that goes up into the car somewhere. I am not sure if that is where the sensor is or not. It is hard not having a specific manual for this model to show where stuff is hidden. I know every spider pre 82 but this one is a real learning experience. It really comes down to knowing what to look for while you are under there and I haven't a clue at this point.

The only manual I have for the 3HP22 is for a Peugeot and that set up is different in the car. The guts for the trans is the same but that is about all in similarity.

Someday I will delve in to the trans and rebuild it and then I will know the intricacies of what it entails.

I drove the car around the neighborhood today again to be sure and the odo/speedometer is definitely not working. Everything else on the car works,
 

·
Registered
Joined
·
7,371 Posts
have you checked fuses #7 & #8 (speedo fuses for manual spider, can't see why the auto spider would be any different)
 

·
Premium Member
Joined
·
3,546 Posts
have you checked fuses #7 & #8 (speedo fuses for manual spider, can't see why the auto spider would be any different)
If the fuse is blown, I think the reverse lights won't work either.

Its a quick check. So is pulling the fuse to see I guess. :smile2:

Good luck,

Vin
 

·
Registered
Joined
·
4,549 Posts
Discussion Starter #10
I will recheck the fuses. Stranger things have happened. If that isn't the cause then we have to look elsewhere. I will have to download a speedometer app for my phone and monitor the speed that way until we can figure out what is going on
Thank you to all that are helping here. :)
 
1 - 10 of 10 Posts
Top