Alfa Romeo Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hello all I just purchased a 1989 Spider Qudrifoglio. The car has been sitting for 16 years I dropped it off at the mechanics we did a tune up changed fluids refurbished the gas tank and fuel sender and the car feels gutless and won’t rev freely. Has anyone had these problems on there Alfa ?
 

·
Premium Member
Joined
·
13,150 Posts
Check the fuel pressure when you rev the engine. A weak pump or partly clogged fuel can cause the pressure to fall off as rpm rises.
 

·
Premium Member
Joined
·
13,150 Posts
Was it the filter or the pump?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
Was it the filter or the pump?
The pump clogged up from loose debris left in the lines.
The car runs amazing now !

Thanks for asking !

I just have a few leaks to take care of

the master cylinder has a slow leak and theres a small coolant leak that's easy to repair
 

·
Registered
Joined
·
110 Posts
You may want to take a peak inside the fuel lines and check for rust. I had to have my steel lines redone in SS. Would be wise to have your fuel injectors sent to be cleaned and flow tested as well.
 

·
Premium Member
Joined
·
13,150 Posts
Would be wise to have your fuel injectors sent to be cleaned and flow tested as well.
Do you think that the car would be running "amazing" with fouled injectors? Also, there is a fuel filter downstream of the pump to keep crap out of the injectors.
I installed an industrial Y strainer upstream of the pump on a GTV6 that had loose scale in the tank and it saved the pump from damage.
 
1 - 8 of 8 Posts
Top