Alfa Romeo Forums banner
1 - 7 of 7 Posts

· Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I've had my Spider for 1-1/2 years, Just recently it started sputtering when I first start it (It sounds just like a VW Beetle) It goes away when it warms up, but it does not do it if the car has been sitting in the sun all day. Only seems to happen in the morning.
 

· Administrator
Joined
·
19,178 Posts
First look through the L-jet Spider Diagnosis page (link below) for lots of things you can do at home. L-jet is a system - all the bits have to work right for it to work right.

Keep in mind that L-jet is very intolerant of air/vacuum leaks so look very closely for any problems there - loose clamps, split hoses, etc. Also the OVS (Oil Vapor Separator) can get clogged and mess with sump scavanging which makes it act like an air leak. Soak the OVS in solvent, rinse & repeat until you get out as much gunk as possible.

How old are the spark plugs, wires, cap & rotor? And the fuel filter?

If everything cheap & easy checks out then consider having the fuel injectors serviced. See the link below to OK injectors for more info about what they do.
 

· Registered
Joined
·
759 Posts
Is it hard to start or just sputters after starting. If more difficult to start you may want to check/clean the AAV as mine used to do that as well. After cleaning and adjustment it stopped.
 

· Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
Is it hard to start or just sputters after starting. If more difficult to start you may want to check/clean the AAV as mine used to do that as well. After cleaning and adjustment it stopped.
It starts fine, it just sputters and runs sluggish from start (low revs)
This only happens in the mornings.

I will check all, thanks for now :mad:)
 

· Registered
Joined
·
10 Posts
Discussion Starter · #7 ·
First look through the L-jet Spider Diagnosis page (link below) for lots of things you can do at home. L-jet is a system - all the bits have to work right for it to work right.

Keep in mind that L-jet is very intolerant of air/vacuum leaks so look very closely for any problems there - loose clamps, split hoses, etc. Also the OVS (Oil Vapor Separator) can get clogged and mess with sump scavanging which makes it act like an air leak. Soak the OVS in solvent, rinse & repeat until you get out as much gunk as possible.

How old are the spark plugs, wires, cap & rotor? And the fuel filter?

If everything cheap & easy checks out then consider having the fuel injectors serviced. See the link below to OK injectors for more info about what they do.
Thanks for the links, I will work on that!
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top