Alfa Romeo Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter · #1 ·
A/C on my '86 Veloce works. Cold air blows fully out only out of the vent by the glove compartment other 6 (left, three central, and two facing up just feel cold but hardly any air comes out.)

I keep the left lever all the way down to "cold", and the right lever in the center (neither defrost- fully up, nor fully down.)

I have noticed considerable air coming out at passenger feet when the A/C fan is at MAX (3).

When I drove with A/C on, after stopping, considerable amount of moisture discharged at passenger feet area. The discharge was quite filthy, brown.

My guesses: blocked ducts, disconnected ducts, rusted components...squirrel nest (the car had its share of those.)

Any ideas? Recommendations?

Should I, with conceptual understanding, but limited to non-existent mechanical experience, attempt to open the fan and that general area and see if I can fix it?
 

·
Registered
Joined
·
861 Posts
Sounds like the water is coming from a plugged or broken drain hose. You can see from the passenger footwell. It drains out the bottom of the car just like any other. Shooting some air into is PITA to clean it. My two center hoses where disconnected by who ever put the radio in and it was pain to reconnect them. I noticed it when I put a new radio in.
 

·
Registered
Joined
·
3,255 Posts
If it works similar to my S4 '91, you should shut OFF the heater control lever entirely (move it downward). Then see if that improves the air delivery through the ducts. If not, then pull the radio out and check to see if the ducts are connected well to the diffusers. They just pop onto the hubs, and it's true that when people fiddle with radio installations, they sometimes pull the hoses off the distribution plenum.

On the AC drain hose, pull it off the housing and clean it out using compressed air or a stiff wire. Does the AC fan run ok? Noisy? I'm thinking of the squirrels you mentioned...

Dave in KY
 

·
Registered
Joined
·
6,087 Posts
The A/C blows air only through the 2 side vents at the end of the dash and the 3 middle vents on top of the radio opening. The defrost and heater vents are the two on top of the dash and the ones on each side (driver and passenger) of the foot-wells. The two levers in the center console control the air coming that comes through the vents on top of the dash and foot-wells.

It is not unusual to find A/C hoses disconnected or improperly connected on Spiders, as they are difficult to re-connect properly if they have been removed. Nonetheless, a properly working A/C in a series 3 Spider will freeze you out of the car, so IMHO, it is worthwhile getting it back up to spec.

Best regards,
 

·
Registered
Joined
·
118 Posts
Discussion Starter · #5 ·
Thank you everybody for the ideas and advice.

As always I am grateful for your time and generosity.

All ideas you gave make pre-eminent sense. I shall do, or at least attemt, all the procedures you recommended.

Thank you all again.

Simon
 
1 - 5 of 5 Posts
Top