Alfa Romeo Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter #1
Howdy, I notice my front left signal stopped working. Upon removing the bulbs I found them to be good. The sockets look good without any corrosion to see. I can't see how it would be a fuse or relay as only one signal is out. Or am I off base there. It IS and Italian car afterall. Is there a seperate realy or fuse for each corner?
 

Attachments

·
Premium Member
71 Berlina 74 GTV 17 Giulia Q4
Joined
·
6,632 Posts
Most likely a ground wire. Follow the black wire from the bulb back to where it connects to the body, take it off and clean it and that should:) do it.
Not to many pepople say howdy except Ags, you haven't spent anytime in College Station have you? long shot I know but I had to take it
 

·
Registered
Joined
·
99 Posts
Discussion Starter #3
Most likely a ground wire. Follow the black wire from the bulb back to where it connects to the body, take it off and clean it and that should:) do it.
Not to many pepople say howdy except Ags, you haven't spent anytime in College Station have you? long shot I know but I had to take it

Thanks for the tip, I'll check it at lunch time today. I used to live in the Northeast Kingdom (Upstate Vermont) Where my mom's family is. Howdy is fairly common the too. Every now and then I regress... LOL
 

·
Registered
Joined
·
585 Posts
Hi Gigem'75. Just to show how small the world is...I taught Geology for freshmen ..called the course....Rocks for Jocks..from 62-68, or so at A&M. Got there that summer ..then Bear Bryant left...I left when they (against all I stand for) let women into the corps. Anyhow..GIGEM' AGGIES
 

·
Registered
Joined
·
860 Posts
I would check and clean the fuses also. I think it is wired left front and right rear on one fuse.
 

·
Registered
Joined
·
99 Posts
Discussion Starter #6
Most likely a ground wire. Follow the black wire from the bulb back to where it connects to the body, take it off and clean it and that should:) do it.
Not to many pepople say howdy except Ags, you haven't spent anytime in College Station have you? long shot I know but I had to take it
Well you were correct, kinda, I found some loose wires when I follwed the harness backwards from the turn signal. Thanks for pointing me in the right direction..... Steve
 
1 - 6 of 6 Posts
Top