Alfa Romeo Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
On my Spider that I bought as a project, I'm having a bit of an issue. I'm a FIAT mechanic, and this is a bit different, lol. When I turn the key to on, fuse number 7 blows every time. What does this fuse do? Also, My inline pump, a jerry rigged Mallory hi-performance pump, is getting NO power whatsoever. Fuel from the in-tank pump is getting there, but this pump isn't pumping... whatsoever. I took the pump off and crossed the leads onto the battery, and the pump itself works brilliantly. Some genius extended the fuel pump wires to reach the pump, and I don't know if the correct wire is going to the correct wire. Is fuse number 7 fuel pump power? It'd be nice if my 2 issues are compounded with one fix..ha.. thanks much. Another question, while asking things here... Where is the headlight switch???? I CAN'T FIND IT ANYWHERE!!!! lol Thanks again
 

·
Registered
Joined
·
1,243 Posts
Fuse 7 should power the reverse lights. The pump fuse should be behind the pass seat under the package shelf (at least in the L-jet models). Headlight switch shouyld be on the left side of the steering wheel behind the turn signal switch (it is a rotary switch)
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3 (Edited)
Thanks for the reply, and the info on the headlight switch... The lights themselves are disconnected so it makes finding the proper switch rather difficult..ha.. Ok, someone has been in the fuse pump control area on my car and spliced a couple wires. A red wire was cut, and has a wire with 2 fusable links added to it.. the fuses are good, and the pump relay clicks when the car turns to on, ye the main in-line pump gets no power whatsoever... any ideas?? I put a light tester on the wire connected to the positive side of the pump, and it had power going to it
 

·
Registered
Joined
·
1,243 Posts
I would think if there is power to the pos side, and the pump tests good, then the prob must be with the ground side. ( neg?). Make sure all the connections and esp grounds are as clean as you can make them. Maybe try bypassing the gnd wire with a known good wire.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
This will be my next chore... As I said, someone, who thought he was working on a Cheverolet, apparantly, has been fiddling with it, so I've got work to do here..ha.. Thanks for your replies
 

·
Registered
Joined
·
1,243 Posts
It would be a good idea to ask Papajam on this site for a copy of his schematics for your car. Using this schematic, I would also try to return the system to its original configuration and work from there. It will give you a known starting point. Good luck. I'm sure others here will have useful info to help you.
 

·
Premium Member
Joined
·
16,232 Posts
Fuse #7: If I had to wager, my money would be on a shorted lighter assembly. In addition to the lighter, this fuse powers the gauges, fan and, as mentioned by Forzaguy, the reverse lights. Please send me your email address and I'll send you the wiring diagrams.

Fuel pumps: it is worth knowing that after about a half second after the ignition key is turned on, there should be NO power to either fuel pump. The pumps are powered only if A) the engine is cranking or B) the engine is running.
I'm with Forzaguy, return the pump wiring to stock and go from there.
 
1 - 7 of 7 Posts
Top