Alfa Romeo Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
216 Posts
Discussion Starter #1
I noticed the other day on a night time run that I had no parking/dash lights. and what I read from my 86 manual is not really too much help. Is there a parking lamp relay? I have 8 fuses in the normal spot under the dash and 2 extra fuses to the left, all of them are intact.

Headlights/brake/backup/signal lamps illuminate. I do not have a owners manual but can read some of the info on the fuse holder cover and I may have exhausted the easy things. Steering stalk assembly?

Before I dig in and make a problem larger than it is any suggestions?

Thanks in advance,
 

·
Premium Member
Joined
·
14,002 Posts
Probably a poor contact in the switch. There are threads with pictures about fixing the switch. Do a search. The fix is not difficult.
 

·
Premium Member
Joined
·
14,002 Posts
So I gather that is a no on the parking lamps relay
Adding light relays is a popular and worthwhile modification but they were not part of the factory wiring.
 

·
Richard Jemison
Joined
·
7,381 Posts
Lights

Another check:
With the key and headlights off if you move the turn signal stalk to either left or right position, the approiate lights should remain on but not blinking. (park lights for road side only.
Could be a connection fault either at the switch, but more likely in the morass of wiring behind the fuse panel.
 

·
Premium Member
Joined
·
14,002 Posts
Send a PM to papajam and get a wiring diagram from him.
 

·
Registered
Joined
·
216 Posts
Discussion Starter #8
I will get to that point soon, I have all the lights working except the front right parking. No power at that corner which also powers the hood lamp circuit. Yellow wire disappears into the harness and back behind the fusebox. Probably in there is the junction for the right/left-front/rear conbination italians came up with, the rear works. I can jumper the light off of the side marker light for now under the hood.

Thanks
 

·
Super Moderator
Joined
·
10,599 Posts
So I gather that is a no on the parking lamps relay
Yes, that is a "no".

The parking lights don't draw that much current, so it wouldn't make sense to put a relay in that circuit. The factory certainly didn't install one.

Alfa owners frequently add relays for the main headlight H and L beam circuits. But again, the factory didn't do that (at least, not in pre-1980's era cars).
 
1 - 9 of 9 Posts
Top