Alfa Romeo Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
216 Posts
Discussion Starter #1
If someone can look a s2 spider at the wiring harness that crosses the radiator near the hood lamp switch and give me some info I would appreciate it.

here's what I have....near the front right I have two yellow wires coming out of the harness that are miswired for the corner/side lamps. wiring diagram shows one wire from the harness. I have a 79 spider and a lot of my wires are painted red because of a PO paint job. My 82 has only one yellow/black wire so it is not much help

Thanks in advance

Joe
 

·
Premium Member
Joined
·
887 Posts
I believe yellow wires feed both the side markers and then blinkers. LH blinker has blue/black feed, and RH blinker has solid blue feed. So a yellow feeds to each side marker, with a black earth or ground also coming from each side marker to body. Headlights...green/black and gray/black feeding LH headlight, with solid green/solid gray feeding RH headlight. The yellow wire also feeds the underhood light.
This seems consistent with '77 and '78 Spiders, so I would imagine it might be the same for the '79.
If in doubt, drop a PM to Papajam, give him details of the car, and he will respond with an easy-to-follow colour-coded wiring diagram. This man is a STAR !
 

·
Registered
Joined
·
216 Posts
Discussion Starter #3
Yes I believe you have the colors right but there are two spade connections with yellow wires and any combination of them I cannot get all the lights working at one time. One spade is for the hood light and the other? Do both yellow wires go to one spot? Ground wires are good
Wiring drawing only shows one yellow from harness for the corner,(from PapaJam)

joe
 

·
Premium Member
Joined
·
887 Posts
Just popped the bonnet and had a look...

On my car (all original, AFAIK, but UK spec...) There is a harness coming down RH side of engine bay, which then crosses the engine bay ahead of the radiator. At the point it turns to cross the car, there is a break out of wires heading out towards the front of the car. 3 yellow leads (one to blinker, one to sidelight, and one paired with a black that runs in the bonnet cavity and pops out to feed the under bonnet light. There is also a green and gray (to RH headlight) and blue to feed the RH blinker. A violet also breaks out here for the pair of horns. The (smaller) bundle crosses the car, and as it terminates, there are the 2 yellow wires (one for sidelight, one for blinker), a green/blk and gray/blk to feed LH headlight, and a blue/blk to feed the LH blinker. So all of that tallies with the wiring diagram.
 

·
Registered
Joined
·
216 Posts
Discussion Starter #5
Looked at it further, yes three yellow wires. One to side marker parking and the other 2 which I have broken/red painted on languishing in the open. The one that goes to the front parking light contact does not have any 12v on it so I believe there may connection further up the line that may be faulty. My wiring diagram does not show 3 yellow if yours does can I get a snapshot?

Joe
 

·
Registered
Joined
·
216 Posts
Discussion Starter #6
Ok cut off some of the main harness tape and found one yellow feeding to a female spade with another yellow crimped with it going to the front harness. the Male spade goes to the side marker. Out of the front harness another yellow wire feeds back into the main harness and pops out to feed the hood lamp circuit. I had to cut/recrimp off two of PO's spade connectors to get the gender straight. now I have lights and I fixed the horn today. Thanks for the assistance.

Joe
 
1 - 6 of 6 Posts
Top