Alfa Romeo Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
ok guys,
I have put a few posts out already about me car...now here is another one

Being new to the World of Alfa Romeo there are still a few Rocks i cannot leave unturned. My '79 Spider has a side mounted Weber carb (2 pack). Which i believe to need replaced. I live in Ohio and have contacted a few places trying to find a rebuild kit to try and fix the problems. My car seems to be "slipping" but i have already replaced the points! So now i really think that it is a carb going bad. Does anyone know of where i can buy a rebuilt kit or any way to try and fix the carb that is in the car the way it is.

please advise!:confused:
 

·
Registered
Joined
·
9,968 Posts

·
Premium Member
Joined
·
23,899 Posts
Agreed, always do a full electrical tuneup before messing with the carbs. Check the fuel pump and fuel filter(s) too.
A US 79 Spider would have come with Spica, so this is converted, presumably. Got pics to see how well the conversion was done?
"Slipping" is a hard symptom to understand outside of clutches.
Andrew
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
hey guys... i didnt mean slipping i know thats what i said but i had just spent 20 straight hours working on the car and was exhausted....i mean PAUSING... I do know the people i bought the car from tried to rewire the car on their own....they did it wrong. all of the fuses are too big and are still blowing!!!!! i will get some pics on here as soon as i can right now i have the car opened up and am getting ready for the task of re-rewiring haha
 
1 - 5 of 5 Posts
Top