Alfa Romeo Forums banner

21 - 26 of 26 Posts

·
Premium Member
Joined
·
5,442 Posts
I know you said you've replaced the plugs twice but what you are describing is exactly what i experienced with my SPICA 2L recently. Brand new NGKs, i noticed erratic pulsing when using the timing light. You might try using the timing on each wire and see if you have a consistent pulse.

BTW, the Centerline dizzy i have uses a Pertronix module. While I've not had trouble with the dizzy i have had a number of Pertronix go bad on me....
 

·
Premium Member
Joined
·
13,090 Posts
There have been stories of bad Bosch coils made in Mexico. A failing coil could cause your symptoms. What coil resistance is specified for your distributor?
 

·
Registered
Joined
·
324 Posts
Have you checked for arcing spark? You need to do this in a pitch-black environment. At night, lights off, a heavy blanket or tarp over the engine compartment. Look for arcing at coil, dizzy cap, along secondary ignition wires and their connection to the spark plugs.
 

·
Registered
Joined
·
700 Posts
Discussion Starter #24
I know you said you've replaced the plugs twice but what you are describing is exactly what i experienced with my SPICA 2L recently. Brand new NGKs, i noticed erratic pulsing when using the timing light. You might try using the timing on each wire and see if you have a consistent pulse.

BTW, the Centerline dizzy i have uses a Pertronix module. While I've not had trouble with the dizzy i have had a number of Pertronix go bad on me....
Thanks for the comment - what was your solution? Another set of plugs?
 

·
Registered
Joined
·
700 Posts
Discussion Starter #25
There have been stories of bad Bosch coils made in Mexico. A failing coil could cause your symptoms. What coil resistance is specified for your distributor?
My coil has about 1000 miles on it. It's the blue Bosch from Centerline.

My diz is a Marelli S103B. I don't know the recommended resistance.
 
21 - 26 of 26 Posts
Top