Alfa Romeo Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter #1
Hi

Last sunday I bought a 1987 Alfa Romeo 75 1.8 Turbo. It´s from the first serie. There are 3 years that the car does not work.
Today I started confirming all the electric conections and verify if no component is missing on the car.
Fortunately I think nothing is missing.
Then I turned the engine by hand some turns and verified that it did not offer any abnormal resistance.
I also checked the oil and it looks very good (it looks new) even if it has 3 year…
I placed a battery and with some care I tried to fire the engine.
Only that the stupid thing doesn´t give any signal of wanting to start.
However, I made the following verifications:

- It seems to me that there are 2 gasoline pumps, since I hear 2 hummings from the back of the car.
- There is gas and pressure at the injection rail
- The injectors have energy. I checked that with a multi tester
- The sparks have Power

But the car does not work
What can I do?

Regards

Carlos Oliveira
 

·
Registered
Joined
·
4 Posts
hi
have you changed the sparkplugs? check if there is electricity in the spark plug's wires, check the air filter also
could be a blockage in the fuel lines, fuel not running properly
i think you should change the engine oil, it lasts for a certain period or miles i think.
good luck
 

·
Registered
Joined
·
89 Posts
Discussion Starter #4
Crag I don´t know if the injectors are blocked. I didn´t try them off the engine. I just checked that the connector has electricity, since I cranked the engine and the tester showed a pulsing tension, so they have power.

"Fiat 127" I didn´t change the sparkplugs, but I´m 100% sure the the HT leads have power, because I tried it with an old spark and it fired. (the spark)
The air filter is very old and looks bad, so I removed it.
I dont think there is a blockage in the fuel lines, because I have fuel pressure on the injectors rail.
As for the oil, I will change it after I can start de engine.
I´m not going to spend money in it before I´m sure it´s OK.

Regards

Carlos Oliveira
 

·
Registered
Joined
·
1,736 Posts
Has the fuel been sitting as long as the car? If so, change it and get the injectors cleaned as old can fuel leave a gummy deposit that can clog filters and injectors. And as it gets old and can loose it's volatility (doesn't like to burn).
Hope that helps. ;)
 

·
Registered
Joined
·
89 Posts
Discussion Starter #6
So, if I understand correctly, if it has gas on the injectors and spark on the plugs, it should start, isn´t it?
Tomorrow I will get the plugs out and check if the injectors are doing there job...

Regards

Carlos Oliveira
 
1 - 6 of 6 Posts
Top